10.0.x: Failed to start notification server: mysql: Error 1045: Access denied

I added [notification] section to the seafile.conf as per manual,
but the notification server fails to start. The database log shows the follow error every minture or so:

Failed to connected to mysql: Error 1045: Access denied for user ‘myuser’@‘localhost’ (using password: YES)

notification-server.log has the same log record, however notification_server_error.log file is empty.

Any idea please?

What’s your [notification] block look like in seafile.conf?

Can you manually log into the database using the user specified in [database] in seafile.conf?

Did you run:

sudo pip3 install future==0.18.* mysqlclient==2.1.* pillow==9.3.* captcha==0.4 django_simple_captcha==0.5.* djangosaml2==1.5.* pysaml2==7.2.* pycryptodome==3.16.* cffi==1.15.1

(assuming this is Ubuntu, etc.).

The notification block is a copy-paste from the manual, and I generated a random jwt_private_key

enabled = true
host =
port = 8083
log_level = debug
jwt_private_key =

Yes, I can login manually using the [database] credentials
Yes, I did install all these dependencies

I also tried to start the server directly using:
./seafile/bin/notification-server -c /fullpath/seafile/conf -v 10
but it logs the same error and quits.

Is there an anonymous user ''@'localhost' or ''@'' in MySQL?

no, just “root” and a user for seafile server:

SELECT user, host FROM mysql.user;
| User | Host |
| root | |
| root | localhost |
| myuser | localhost |

I found a problem. I had a “#” symbol in the password. Once removed, notification server has started finally. Please fix it in the next version

You mean ‘illegal’ character in password?

No, I mean complex passwords which notification daemon can’t handle

Hello @anton123, we will look into this problem.