502 Gateway on local IP. Fresh install on docker-ompose

Fresh install of seafile using dockercompose has error 502 when attempting to access on local address; 192.168.0.143:9087 i have tried all other ports too

here is my yaml;

---
version: "2.0"
services:
  db:
    image: mariadb:10.5
    container_name: seafile-mysql
    environment:
      - MYSQL_ROOT_PASSWORD=password #Requested, set the roots password of MySQL service.
      - MYSQL_LOG_CONSOLE=true
    volumes:
      - /docker/seafile-mysql/db:/var/lib/mysql  # Requested, specifies the path to MySQL data persistent store.
    networks:
      - seafile-net

  memcached:
    image: memcached:1.6
    container_name: seafile-memcached
    entrypoint: memcached -m 256
    networks:
      - seafile-net
          
  seafile:
    image: seafileltd/seafile-mc:latest
    container_name: seafile
    ports:
      - 9087:80
      - 9086:8002
      - 9085:8080
      - 9084:8000
    volumes:
      - /docker/seafile-data:/shared   # Requested, specifies the path to Seafile data persistent store.
    environment:
      - DB_HOST=db
      - DB_ROOT_PASSWD=password #Requested, the value shuold be root's password of MySQL service.
      - TIME_ZONE=Europe/London
      - SEAFILE_ADMIN_EMAIL=email.example.com # Specifies Seafile admin user, default is 'me@example.com'.
      - SEAFILE_ADMIN_PASSWORD=password #Specifies Seafile admin password, default is 'asecret'.
      - SEAFILE_SERVER_LETSENCRYPT=false   # Whether to use https or not.
      - SEAFILE_SERVER_HOSTNAME=seafile.domain.com # Specifies your host name if https is enabled.
    depends_on:
      - db
      - memcached
    networks:
      - seafile-net

networks:
  seafile-net:

to fix this i have edited; /shared/nginx/conf/seafile.nginx.conf
and exchanged all localhost 127 ports with 0.0.0.0 but this didnt work.

i have also added rules for ports 9084 - 9087 using sudo ufw allow [port]

Can anyone help with this??