6.0.1 Internal Server Error

I have same error with any version newer than > 5.1.7 (Internal Server error)

Today tried 6.0.1 beta / Seafile / Seahub started with no problems:

but in browser:
Internal Server error

have you installed python-urllib3 via Seafile Server 5.1.4 is ready! Quite a few fixes

and is there any useful info in ../logs/*.log ?

1 Like

Thank you lian,
it worked

Hi,

I upgraded my seafile server 6.0.9 to 6.3.4 on my raspberry… And the result is “Internal server error”.
Apache is not working and I don’t no why, because I’m a beginner in web server…

pi@serveur:/media/pi/252d20eb-8ec9-4007-b327-ea678931ef2b/seafile/seafile-server-6.3.4 $ systemctl status apache2.service
â—Ź apache2.service - LSB: Apache2 web server
Loaded: loaded (/etc/init.d/apache2)
Drop-In: /lib/systemd/system/apache2.service.d
└─forking.conf
Active: failed (Result: exit-code) since Wed 2018-12-26 16:48:19 EST; 10s ago
Process: 18538 ExecStart=/etc/init.d/apache2 start (code=exited, status=1/FAILURE)

There is my 000-default.conf file in /etc/apache2/sites-available:

VirtualHost *:80>
ServerName 192.168.1.5:8000
# Use "DocumentRoot /var/www/html" for Centos/Fedora
# Use "DocumentRoot /var/www" for Ubuntu/Debian
DocumentRoot /var/www
Alias /media  /home/user/haiwen/seafile-server-latest/seahub/media

RewriteEngine On

<Location /media>
    Require all granted
</Location>

#
# seafile fileserver
#
ProxyPass /seafhttp http://127.0.0.1:8082
ProxyPassReverse /seafhttp http://127.0.0.1:8082
RewriteRule ^/seafhttp - [QSA,L]

#
# seahub
#
SetEnvIf Authorization "(.*)" HTTP_AUTHORIZATION=$1
ProxyPreserveHost On
ProxyPass / http://127.0.0.1:8000/
ProxyPassReverse / http://127.0.0.1:8000/

I regret to have made the update, it worked very well before…

I use seafile in local network only…

I do a rollback to 6.2.1 and all is done.