Activate elasticsearch


I’m trying to enable search, but it doesn’t seem to work.
I’m on seafile-pro-server-9.0.13 and on Arch Linux.

sudo docker pull elasticsearch:7.16.2

sudo mkdir -p /opt/seafile-elasticsearch/data

sudo chmod -R 777 /opt/seafile-elasticsearch/data/

sudo docker run -d \
--name es \
-p 9200:9200 \
-e "discovery.type=single-node" -e "bootstrap.memory_lock=true" \
-e "ES_JAVA_OPTS=-Xms1g -Xmx1g" -e "" \
--restart=always \
-v /opt/seafile-elasticsearch/data:/usr/share/elasticsearch/data \
-d elasticsearch:7.16.2
vi conf/seafevents.conf

external_es_server = true
es_host = es
es_port = 9200
interval = 10m 
highlight = fvh
index_office_pdf = true
sudo systemctl restart seafile.service 
sudo systemctl restart seahub.service
sudo docker ps                       
CONTAINER ID   IMAGE                  COMMAND                  CREATED             STATUS          PORTS                                                 NAMES
756a78dbb137   elasticsearch:7.16.2   "/bin/tini -- /usr/l…"   About an hour ago   Up 19 minutes>9200/tcp, :::9200->9200/tcp, 9300/tcp   es
cat seafevents.log
[2022-12-22 15:26:50,479] [INFO] work weixin notice sender is disabled
[2022-12-22 15:26:50,479] [INFO] search indexer is disabled
[2022-12-22 15:26:50,479] [INFO] seahub email sender is started, interval = 1800 sec

From File Search - Seafile Admin Manual

NOTE : The version of the Python third-party package elasticsearch cannot be greater than 7.14.0, otherwise the elasticsearch service cannot be accessed:

Hello, I followed this manual page: Installation - Seafile Admin Manual

Since version 9 elasticsearch doesn’t come with seafile.