Adding extra web pages when Seafile is installed to root


I’ve installed Seafile on the root of a sub-domain (i.e. http :// using Apache but I’d like to also be able to get to some other pages displayed by adding something (e.g. http ://

I have to use a sub-domain due to DDNS and ability to set CNAME records with my domain provider. I know that I can move Seafile to something like http :// but I don’t really want to make that so long and people having to remember whatever I put on the end.

I’ve added a robots.txt file to the domain root and http :// returns it but if I try adding an index.html file then that doesn’t load if I try http :// and if I create a sub-directory and put it in there then that doesn’t work either (e.g. http :// or http ://

I tried adding an Alias in the Apache setup

Alias /test /var/www/test

and restarting Apache but that didn’t work either.

One thing I don’t understand is, although http :// returns the file when the Seafile services are running, it doesn’t when the Seafile services aren’t running.

I don’t have any Apache experience other than configuring it for seafile and setting it for https (I have set http to divert to https).


Facing same issue as of now, did you get any way out yet? Tried mailing the stuff of support but got hardly any reply.

R. Smith

No, not found a way yet, might try an Apache forum when I get time to look further but visitors arrived today so I’m not likely to look at it again before next week at the earliest.

I’ve played around with Alias and Location settings after looking at Apache documentation but I still can’t get it to work.

If I put files in the document route then it can’t get them, as I would expect, except for the ‘robots.txt’ which I guess Apache must be treating as a special case.

@respikistu did you have any success?


OK, I’ve looked at this again assuming that the ProxyPass for / to port 8000 is taking precedence.

I had thought that early on but then I was misled by testing that theory against the /media alias which seeming to work if I tried to access a file under that area. But in reality that is presumably being handed by the ProxyPass to port 8000 (or directed back in some way, I don’t really know).

Anyway, I eventually found this

And adding
ProxyPassMatch ^/test !
to my virtual host configuration means that I can now get to ‘http://mydomain/test’ while ‘http://mydomain’ still goes to Seafile. :smile:

Now, if I could only sort out why my directory links want people to login instead of just linking them to the directory to view / download the files! :pray: