After login I get "Page unavailable"

Hello folks,
I’m running Seafile Pro as container in a rootless podman environment using NGINX as a reverse proxy. A HTTP response should take this route:
Client <–> NGINX Port 443 <–> proxy_pass;

Port 8002 is mapped to Port 80 of the seafile container (>80/tcp). I can access the login page at My browser’s address bar shows After loging in as Seafile-Admin I get the error:

Page unavailable
Sorry, but the requested page is unavailable due to a server hiccup.
Our engineers have been notified, so check back later.

My NIGNX configuration looks as follows:

server {
    # Listen on Port 443
    listen 443 ssl http2;
    listen [::]:443 ssl http2;
    add_header Strict-Transport-Security max-age=31536000;

    ssl_certificate …fullchain.cer;
    ssl_certificate_key …;
    ssl_protocols TLSv1.2 TLSv1.3;
    ssl_ciphers '…';

    ssl_prefer_server_ciphers on;
    ssl_dhparam /etc/nginx/dh_params.pem;

    # Path to the root of your installation
    root …/public;

	location ^~ /.well-known/acme-challenge/ {
	default_type "text/plain";
	root …/public;
	location = /.well-known/acme-challenge/ {
	return 404;

	proxy_set_header X-Real-IP $remote_addr;
        location / {
	proxy_read_timeout 310s;
	proxy_set_header Host $host;
	proxy_set_header Forwarded "for=$remote_addr;proto=$scheme";
	proxy_set_header X-Forwarded-Proto $scheme;
	proxy_set_header X-Real-IP $remote_addr;
	proxy_set_header X-Forwarded-For $remote_addr;
	proxy_set_header Connection "";
	proxy_http_version 1.1;

The NGINX access log of my host shows the following entries for each login attempt: - "GET / HTTP/2.0" 302 0 "-" "Mozilla/5.0 (X11; Linux x86_64; rv:109.0) Gecko/20100101 Firefox/110.0" - "GET /accounts/login/?next=/ HTTP/2.0" 200 4000 "-" "Mozilla/5.0 (X11; Linux x86_64; rv:109.0) Gecko/20100101 Firefox/110.0" - "POST /accounts/login/?next=/ HTTP/2.0" 500 285 "" "Mozilla/5.0 (X11; Linux x86_64; rv:109.0) Gecko/20100101 Firefox/110.0"

The logs of the seafile container show no error:

Starting seafile server, please wait ...
** Message: 11:48:51.432: seafile-controller.c(1023): loading seafdav config from /opt/seafile/conf/seafdav.conf

Seafile server started


Starting seahub at port 8000 ...

Successfully created seafile admin

Seahub is started


I appreciate any assistance on solving this issue. Could someone help, please?

I tried to access the seafile contianer instance directly without using the reverse proxy by accessing but I got the same error. Therefore the reverse proxy is not the root case for this issue.

Still have know clue what’s bothering the service or which logs to search.

I was able to resolve the issue by using the Playbook Debugger. The root cause was a that I was using the wrong variable in some task.