After update from 6.2.1 to 6.2.2 Seafile Server CE

Аfter updating of the server repo names in Russian language have changed on “???”


How fix this?

Learn Russian! :grin: Easy :wink:

You can change the language before you login. Top - right.

He, want Russian language! But he have libraries with question mark names.

Did you had library name with azbuka or latin? This doesn’t have anything with UI language choose to do.

EDIT:
Did some testing. Cannot reproduce this bug. Try to shutdown seafile server, drop memcache and start server again.

Following your recommedation I did the restart but it didn’t cause the effect. This error appears exactly re libraries with names in Russian (letters, symbols).I tried to rename the libraries again but after the refresh the page - the question signs symbols “???” appear again.if I use both Latin and Russian letters so latin saved but Russian agin replaced by question signs. for example “???-Folder” .

The same bug appears in Seadrive too. Together with it the name of Russian folders and files are saved properly inside the library.
In admin panel in Library section the names are saved properly.

What type of database are you using? MySQL or SQLite?

Can you access to database and put here definition of table table RepoInfo in seafile(not seahub or ccnet) database?

I think there’s problem with char encoding. I’m running 6.2.2 too and don’t have problem to name library with Russian characters.

ccnet-db and sefile-db for some reason have latin1 encoding, and seahub-db has utf8.
I changed the encoding of the ccnet-db and sefile-db databases to utf8, the problem was solved.
holantomas thanks for the help!

latin1 is on some system as default encoding for mysql. I’m glad that helped you.

Please mark your last reply as solution for other people with same problem.