Android camera upload fail


#1

Good morning,

In my seafile installation on windows, all is fine, but android mobile clients cannot upload camera images and videos… upload failed, also on little files.
I use NGINX with HTTPS, MySQL on WIndows 2008 R2 64-bit, server is 6.0.7.
Client app is 2.2.4 and it works okay.

I am going crazy…
Thank you very much in advance.


#2

The same thing with app v2.2.5…
:frowning:


#3

Seafile Windows server is not really supported anymore.

Go install the latest server version on Linux and try again.


#4

#5

Rolling back to 2.2.1 it runs okay. It is important to set off auto upgrade of the app.


#6

It hasn’t been working for me at all. I’m running Seafile myself and the Android app stops syncing pictures regularly. I have to re-enable syncing in accounts to have my pictures synced up. Any ideas why this happens?


#7

Android terminates the Seafile service that auto uploads the photos because it isn’t registered properly in newer Android releases.

Configure auto upload using Foldersync Pro over Webdav - that’s how I solved the problem.


#8

How’s that solution with battery life?


#9

It’s fine for me. Only thing you can do is test it out yourself.


#10

For me Folder sync stopped working some time ago and its not supported well lately. (just look at the last comments in the app store) As far as i know, the Author mentioned that a one time payment of a pro version doesnt work when you have to maintain the app for several years.

But i found another good app to sync with seafile.
Its called Synchronize Ultimate and is free for 2 profiles.
It has a preconfigured config for seafile and you can use it with webdav or sftp or even other Services.


#11

Synchronize Ultimate constantly failed for me, that’s why I ended up back at Foldersync Pro.

What works for me to make sure things stay up to date and stable with Foldersync is:

  • Use Scheduled Sync, everyday at 5am
  • Also use Instant Sync
  • Retry sync if failed
  • Only resync source files if modified
  • Every other option is turned off

#12

I ran into a similar issue. Turned out the nginx reverse proxy in front of the seafile docker install was limiting the size of uploads. Fixed it by adding the following to the nginx config:

location / {
    ...
    client_max_body_size 1000M;
    ...
}