Android client Network Error

Hi,

I’ve been using seafile for a couple of months now but my Android client stopped working for some reason. I deleted the app and tried to set it up from scratch.
I cannot connect to my seafile server though. I’m getting the message “Network Error”. See screenshot.

Seafile server is running Debian bullseye with seafile 8.0.4. In front of it there’s a dedicated reverse proxy with nginx and letsencrypt.
This is the nginx config:
server {
listen [::]:443 ssl;
listen 443 ssl;

    ssl_certificate /etc/dehydrated/certs/junicloud.lpv4.net/fullchain.pem;
    ssl_certificate_key /etc/dehydrated/certs/junicloud.lpv4.net/privkey.pem;
    ssl_protocols TLSv1.2 TLSv1.3;
    ssl_ciphers ECDHE-RSA-AES256-GCM-SHA512:DHE-RSA-AES256-GCM-SHA512:ECDHE-RSA-AES256-GCM-SHA384:DHE-RSA-AES256-GCM-SHA384:ECDHE-RSA-AES256-SHA384;
    ssl_ecdh_curve secp384r1;
    ssl_session_timeout 10m;
    #ssl_session_cache shared:SSL:10m;
    ssl_session_tickets off;
    ssl_stapling on;
    ssl_stapling_verify on;
    add_header Strict-Transport-Security "max-age=63072000; includeSubDomains; preload";
    add_header X-Frame-Options DENY;
    add_header X-Content-Type-Options nosniff;
    add_header X-XSS-Protection "1; mode=block";
    server_name junicloud.lpv4.net;
    client_max_body_size 256M;
    access_log /var/log/nginx/junicloud.lpv4.net-ssl_access.log;
    error_log /var/log/nginx/junicloud.lpv4.net-ssl_error.log error;
    location / {
            client_max_body_size 256M;
            proxy_buffering on;
            proxy_buffers 12 12k;
            proxy_redirect off;
            proxy_set_header X-Real-IP $remote_addr;
            #proxy_set_header X-Forward-For $remote_addr;
            proxy_set_header X-Forward-For $proxy_add_x_forwarded_for;
            proxy_set_header X-Forwarded-Proto $scheme;
            proxy_set_header Host $host;
            proxy_pass http://my_ip_address:8000;
            add_header X-Frame-Options "SAMEORIGIN";
    }
location /seafhttp {
  rewrite ^/seafhttp(.*)$ $1 break;
  proxy_pass http://my_ip_address:8082;
  client_max_body_size 0;
  proxy_set_header   X-Forwarded-For $proxy_add_x_forwarded_for;
  proxy_connect_timeout  36000s;
  proxy_read_timeout  36000s;
  proxy_send_timeout  36000s;
  send_timeout  36000s;
}
}

Thank you for your help.

Edit:
I’m sorry I forgot to mention it’s a Google Pixel 4a with Android 11.

Anbybody?
Bump!

Isn’t Android as a platform not supported or did I fail to deliver the necessary information?

I created an account for this forum just for this. I have the same problem, and i don’t know why no one is answering you. I hope you already have a solution and post the solution here!
Thanks

oh nevermind, i made a typo in my server adress. Maybe there is also a type in your server address?