Avatar not working in clean install of v8.0.4

Minor problem - the avatar graphic is not displaying correctly as shown below. I’m currently building a new Seafile install in my lab so I can get used to Linux install. So v8.0.4 was installed from scratch:

Configuring an avatar graphic doesn’t help:

As I was a little wary of v8.x, I also have a VM where I’ve installed v7.x first and then upgraded. The problem doesn’t occur that route. So suggests the v8.x install is missing something?

Same VM but running 7.x:

And carries on working during upgrade to v8.x

Inspecting the HTML, it’s linking to a graphic here but that folder doesn’t exit.

Later… it’s missing “:8000” in the IP address…

Later still: I don’t think this entry is correct in system settings:

Okay so that’s the problem. The SERVICE_URL was incorrect in site settings with the v8 clean install. I’m going to go through the set-up again just to double check. The advantage of checkpoints in Hyper-V :slight_smile:

I had to restart the server for the change to make an effect. Guess I might have been able to just restart the seafile and seahub services.

I’ve just repeated this by re-installing v7.1.5 and v8.0.4 from scratch (no upgrades). v7.x gets the SERVICE_URL setting correct:

v8.0.4 gets the wrong requiring a change in system settings and a restart of either the web server or server itself:

Hey Rob … you want to help me instill sea file ? how much would you charge … Susan