Backup/Restore from Drive I.S.E

server

#1

Ok so recently my server had a malfunction so to not wast time i started backing everything up and setting it up on a new server i just built. My issue is that when starting the seahub server it all goes well says its running but going to the host address x.x.x.x:8002 i get an “Internal Server Error”

Could someone tell me how i can resolve this i looked through the logs but can’t see any errors. My server is in the same structure the “Server” and the “seafile-data” files are on the same drive together so i could easily switch it to a new machine if needed. But now it is not wanting to startup correctly.

This is to give an idea as to how to server files are setup. They are all on the same drive as i stated above. Also to reiterate the server did work perfectly fine but my old server machine had malfunctions that resulted me to moving to a new machine. The IP to said machine is a STATIC IP and i did take the old ip and set it to the new machine.
–Structure----------
Drive D:
seafile-data
httptemp
library-template
seafile.db
storage
tmpfiles
Server
ccnet
conf
logs
nano.save
pids
seafile-server-6.3.4
seafile-server-6.3.4_stable_pi.tar.gz
seafile-server-latest
seahub-data << null i am not using this location to store the data
seahub.db

–EDIT–

I am running the PI version of Seahub and the database information is not stored using MYSQL or anything i used the option during setup of the Seahub server to store the data in the .db file.

Screenshot of startup and error


#2

Also within the runtime folder i can not find an error log file at all.


#3

DId you dumped the databases and imported in the new envoirment?


#4

Again the other server A is no longer working the drive used for the server is still intact and in Server B at this time. All data is still in it’s original structure the only difference is that the hard drive running the server is in a new machine


#5

So if I get it. The HDD is the same. The server is a new one, but the same hardware (raspberry).
So what changed?

  • MAC address maybe, so IP address is the same (static or dhcp)?
  • Probably you missed the mounting of the HDD. You should check the /etc/fstab file located in the SD card of your RPI to correctly mount the HDD at startup.

This comes to my mind


#6

on the mounting i haven’t setup the fstab automount but i did go ahead and manually mount it to it original location.

/home/pi/S

When setting up the server in raspberry (Like a new one) it asks to use a current database or make a new one i thought about selecting that but i am afraid it will wipe something important. I’m in the process of making an entire backup of the hard drive in hopes it will fix it.


#7

I ended up doing a fresh install of seafile as a test and my network gets a internal server error.


#8

I think that in new versions (maybe since 7.0, not sure) the default is to bind only to the localhost address (127.0.0.1). It expects you to run nginx or apache or something as a proxy in front of it on the same machine so it only listens to localhost. I had to change that for my setup since my reverse proxy is on a separate VM.

Details here:


#9

See that’s the thing locally it dosent work. Like boot my pi up then open the browser and try to connect I get the same error. I’ve checked all the logs but I have no issues within them. Also i run it using apache.


#10

Ok I figured out the issue I’m doing a little test and I’m going to upload in detail what my issue was it was honestly very simple.


#11

Ok so to trace back on what i did to get to where i am now.

–EDIT:–
This is a fresh install of not just raspbian but also the seafile server is a fully clean slate the drive containing my old server is not connected to the machine at this time.
–EDIT End–

  1. Wiped SD and reinstalled clean (latest) Raspbian.
  2. Booted did my updates and upgrades/ installed all dependencies needed and restarted device.
  3. reboot and redid updates and upgrades.
  4. set my “Static” ip in /etc/dhcpcd.conf.
    –Example–
    interface eth0
    static ip_address=192.168.0.4/24
    static routers=192.168.0.1
    static domain_name_servers=192.168.0.1
    –Example End–
  5. Downloaed latest raspbian seafile server tar.gz. Extracted it and installed using “server-setup.sh” finished filling it out and created admin account.
  6. started it and everything was ok.

Now this is where i checked my netstat and i was given this.
http://109.235.71.203/img/20190709_020701.jpg

At this point i can tell there is an issue so finally for the first time i remove my static ip setup believing this to be my main cause to the issue. Now this did fix each local address from saying “unkown” but now all of my address said this.
http://109.235.71.203/img/20190709_021503.jpg

Now i did change my servers address in conf/ccnet.conf to match the ip set by my router but as of right now it still says the exact same thing. “Internal Server Error” I believe this is something to do with the new update to raspians OS but i really would like to get this to work.


#12

My issue resides in the fact im running raspbian buster and the docker for seafile apparently dosent work with the new version of raspbian ill post updates on if there is a fix.

–Edit–

Went back to the very last update of raspbian stretch and did a clean install of it. Installed all the necessities for seafile server and started my old server up without any extra changes and it all startup up perfectly. Now everything is running just as it did. I learned that the seafile server for rasp is not correctly working with raspbian Buster at the moment hopefully in a newer update it will work correctly. Also at the time of posting this topic i was unaware i had installed RaspBuster since i was also unaware they had released it for the PI4 at the time.


#13

Glad to hear you got it working!

One other thing, just FYI. The names you saw in netstat like “unknownb827eb8308” and “raspberrypi.attlo” don’t matter much. The connection stuff that netstat is showing you really only cares about IP addresses. But netstat thinks that names will mean more to the user than IPs, so it does a reverse DNS lookup of the IP to get the name to show you (unless you add -n to tell it to stick to just the numbers). It only shows the IP if that reverse lookup doesn’t give a name at all. When your pi gets an IP by DHCP it gives its hostname as part of the request, so your router has a name to go with it. When you set an address statically it doesn’t have that. So the name netstat shows shouldn’t change anything for seafile.


#14

Alright thank you i appreciate that :smiley: