Broken web-gui with local installation

Hi dudes,
I’m using seafile for several years with an online root server. So far, so good. But now I want to use seafile in a local lan installation. My goal is to accessing the server within my openvpn connection. The openvpn part is working fine for a long time, so thats not the topic here. I just want to reach the seafile web gui over the local lan, without a domain name and without ssl and so on, because I dont need this.

I’ve installed seafile inside a vm (proxmox) with mysql (mariadb-server) and nginx as root. The server is reachable within my local lan and I’m administrating via ssh.

I tried the process without nginx but just using the gunicorn and this works fine. But if I try to using nginx, the weg gui get screwed up. I will attach a screenshot in here. I’m able to login, but after this I just see a blank screen. Deleting the cache did not help.

Here are a few snippets of my configs:

log_format seafileformat '$http_x_forwarded_for $remote_addr [$time_local] "$request" $status $body_bytes_sent "$http_referer" "$http_user_agent" $upstream_response_time';
server {
	listen 80;
	proxy_set_header X-Forwarded-For $remote_addr;
	location / {
		proxy_set_header	Host $host;
		proxy_set_header	X-Real-IP $remote_addr;
		proxy_set_header	X-Forwarded-For $proxy_add_x_forwarded_for;
		proxy_set_header	X-Forwarded-Host $server_name;
		proxy_read_timeout	1200s;
		# used for view/edit office file via Office Online Server
		client_max_body_size 0;
		access_log	/var/log/nginx/seahub.access.log seafileformat;
		error_log	/var/log/nginx/seahub.error.log;
	location /seafhttp {
		rewrite ^/seafhttp(.*)$ $1 break;
		client_max_body_size 0;
		proxy_set_header	X-Forwarded-For $proxy_add_x_forwarded_for;
		proxy_connect_timeout	36000s;
		proxy_read_timeout	36000s;
		proxy_send_timeout	36000s;
		send_timeout	36000s;
		access_log	/var/log/nginx/seafhttp.access.log seafileformat;
		error_log	/var/log/nginx/seafhttp.error.log;
	location /media {
		root /root/seafile/seafile-server-latest/seahub;


USER_NAME = seafile-proxmox
ID = asdfsadfsdafsdafsadfsadfsadfasdfsdafasdf
NAME = seafile-proxmox

PORT = 13419

ENGINE = mysql
PORT = 3306
USER = seafile
DB = ccnet-db


# -*- coding: utf-8 -*-
SECRET_KEY = "asdfkjasdkfjasdkfjasdlfkjasldfkjalsdkfj"

    'default': {
        'ENGINE': 'django.db.backends.mysql',
        'NAME': 'seahub-db',
        'USER': 'seafile',
        'PASSWORD': 'pw,
        'HOST': '',
        'PORT': '3306'

My first attempt was with a local domain name (with the DNS resolver inside of my pfsense) but with the same results. So at first I want to reach the seafile webinterface with just a ip. To be clear: after the nginx installation, I tried it with “http:” and here you see my results.

I’m thankful for any advise!


Edit: The image-upload in here was not possible, so here is a link (why???):
Edit 2: I’m even not allowed to add a link, so here a new try… delete the blanks…
https:// grG35g5T

Okay, I’ve did it with apache. This works without any problems for me. :slight_smile:

Hi Oneiro,
welcome to the Community Forum.
Glad you made it work with Apache!
If you want to help others, please summarize your experience and your steps to solve the problem.
Also: Please mark the post as solved.