Can not access seafile with domain

Hi,

i can not access my seafilie server with my domain. i did everything from https://manual.seafile.com/deploy/deploy_with_apache.html.

can you help me?

Post your apache virtual host file and your seafile configs (seahub_settings.py, ccnet.conf) and your your unit file for systemd (or your rc.local).

my domain is and i use ubuntu 14.04

virtual host:

ccnet:

[General]
USER_NAME = belumtentu
ID = 3818775353229411be631f15927d03f4fd04c443
NAME = belu
SERVICE_URL =-------

[Client]
PORT = 13419

[Database]
ENGINE = mysql
HOST = 127.0.0.1
PORT = 3306
USER = seafile
PASSWD =
DB = ccnet-db
CONNECTION_CHARSET = utf8

seahub setting:

-- coding: utf-8 --

SECRET_KEY = “kmlfjx9gwg_z9+$^zb9pv6!oz3gd&@5j@6vec$i^uq@qcxwb%*”
FILE_SERVER_ROOT = ‘-----.com/seafhttp’

DATABASES = {
‘default’: {
‘ENGINE’: ‘django.db.backends.mysql’,
‘NAME’: ‘seahub-db’,
‘USER’: ‘seafile’,
‘PASSWORD’: ',
‘HOST’: ‘127.0.0.1’,
‘PORT’: ‘3306’
}
}

Thank you in advance

The apache modules are enabled?

sudo a2enmod rewrite
sudo a2enmod proxy_http
sudo a2enmod proxy_fcgi

Try to add the following to your seahub_settings.py:

SERVE_STATIC = False

Did you start seafile with fastcgi (as seafile user)?

./seafile.sh start
./seahub.sh start-fastcgi

now i can access my seafile with my domain.
but now i have a new problem

how can i fix it?

thank you

Check the file permission.

Make sure to exchange secret key in case it is being used in production.

its just for my lab. i build with another server for my production

and its works. thank you everyone

I use Seafile with a subdomain (https://blabla.de/seafile). For that I have to add more lines to my seahub_settings.py to get the right web frontend:

MEDIA_URL = '/seafmedia/'
SITE_ROOT = '/seafile/'
COMPRESS_URL = MEDIA_URL
STATIC_URL = MEDIA_URL + 'assets/'

Perhaps you must add the line with MEDIA_URL to your settings file