Can see shared dir, but it is empty

We have a shared dir among a few users. it shows that it has 5.5 gb in it. no one, not even the creator can see any files in the dir.

if i log in as admin it shows the dir and its size
server is 7.1.3. The problem started after upgrading from 7.0.2

any idea how to fix this? the files are important so we would like to get them back.


Have you tried running seaf-fsck on your repos? Also, have you checked the repo folder from the OS level to see if the size there roughly matches the 5.5 gb reported by Seafile?

Thanks for the reply,
Yes I tried seaf-fsck, it found a lot of errors and tried to correct them.
Unfortunately the user how uploaded them only uploaded them and does not have a local copy. So i can’t check the OS level

What I meant by OS level was on the server machine and not the user’s machine. From the terminal, run a sudo du -sh /path/to/repo/folder/in/question. If the size reported roughly matches what you see in the Seafile web interface, then the files are still there… If it’s empty or much smaller, the files are lost unless you have history for that repo turned on.