Can’t create admin user: Error happened during creating seafile admin

Hi,
I am using in ubuntu 20.04.2, and I try to install seafile-server-8.0.4 manually.

I am using the documentation : deploy using mysql

I have the problem at the step :“Running Seafile Server”.

All is right for ./seafile.sh start

But, it’s wrong for ./seahub.sh start

root@InstanceSeafile:/opt/seafile/seafile-server-8.0.4# ./seahub.sh start

Starting seahub at port 8000 ...

----------------------------------------
It's the first time you start the seafile server. Now let's create the admin account
----------------------------------------

What is the email for the admin account?
[ admin email ] axxxxxxxx@xxxxxxl.com

What is the password for the admin account?
[ admin password ]

Enter the password again:
[ admin password again ]

Error happened during creating seafile admin.

Error:Seahub failed to start.
Please try to run "./seahub.sh start" again

I did this test seen in an other topic :

root@InstanceSeafile:/opt/seafile/seafile-server-8.0.4# python3 check_init_admin.py
Traceback (most recent call last):
  File "check_init_admin.py", line 19, in <module>
    from seaserv import ccnet_api
ModuleNotFoundError: No module named 'seaserv'
root@InstanceSeafile:/opt/seafile/seafile-server-8.0.4# ^C

I do the complete installation on a bionic serveur - ubuntu 18, and I have a similar error :

root@InstanceSeafileBionic:/opt/seafile/seafile-server-8.0.4# ./seahub.sh start

Starting seahub at port 8000 ...
Error:Seahub failed to start.
Please try to run "./seahub.sh start" again
root@InstanceSeafileBionic:/opt/seafile/seafile-server-8.0.4# ^C
root@InstanceSeafileBionic:/opt/seafile/seafile-server-8.0.4# python3 check_init_admin.py
Traceback (most recent call last):
  File "check_init_admin.py", line 19, in <module>
    from seaserv import ccnet_api
ModuleNotFoundError: No module named 'seaserv'
root@InstanceSeafileBionic:/opt/seafile/seafile-server-8.0.4#

Oki,
I did an other installation, on ubuntu bionic (version 18), with seafile 7.1.5… and now it is oki !
My conclusion : Theres some problemes with the other configuration.
For all installation, I use the documentation online : deploy using mysql ! I only use the right installation line of python, …
Very Strange.
All times, it is new installation, new instances.

root@InstanceSeafile7Bionic:/opt/seafile/seafile-server-7.1.5# ./seahub.sh start # Start seahub website, port defaults to 127.0.0.1:8000

LC_ALL is not set in ENV, set to en_US.UTF-8

Starting seahub at port 8000 ...

----------------------------------------

It's the first time you start the seafile server. Now let's create the admin account

----------------------------------------

What is the email for the admin account?

[ admin email ] axxxxxxxxn@gxxx.com

What is the password for the admin account?

[ admin password ]

Enter the password again:

[ admin password again ]

----------------------------------------

Successfully created seafile admin

----------------------------------------

Seahub is started

Done.

root@InstanceSeafile7Bionic:/opt/seafile/seafile-server-7.1.5#

Can anybody give me some advice what I could do?

Thanks in advance!

Hi,

Is there any chance your issue is similar to this one (Seafile 8 with MySQL 8 seems broken out of the box) ?

Hi, thanks for your answer.
I saw this question, that’s why i did the test : “seafile@seafile-test:~/seafile-server-latest$ python3 check_init_admin.py”

The answer of the test was not the same of this user.
And the command line " ```
ALTER USER ‘seafile’ IDENTIFIED WITH mysql_native_password BY ‘secret’;


Best regards