Cannot get the webdav secret to work to sync with Joplin

Good day,

I am trying to set up a seafile server for my personal use. I had started out with the Pro edition but after seeing that this issue had been resolved in CE 8.0.4 I shutdown my server and moved over the the CE edition.

I have the server up and running and everything works including the Webdav sync. However, when I enable 2FA the sync is broken. Which is expected.

I have made the required change to my file as stated in the docs.

It now looks like this:

   # -*- coding: utf-8 -*-

        'default': {
            'ENGINE': 'django.db.backends.mysql',
            'NAME': 'seahub_db',
            'USER': 'seafile',
            'PASSWORD': 'PASSWORD',
            'HOST': 'db',
            'PORT': '3306'


    CACHES = {
        'default': {
            'BACKEND': 'django_pylibmc.memcached.PyLibMCCache',
            'LOCATION': 'memcached:11211',
        'locmem': {
            'BACKEND': 'django.core.cache.backends.locmem.LocMemCache',
    TIME_ZONE = 'ect/UTC'

I have confirmed that the changes made to the file are read by the server since the Login attempt setting works.

The docs say that pycryptodome==3.7.2 needs to be installed first. I installed in in the container using
sudo docker exec seafile pip install pycryptodome==3.7.2
however, it still does not work. I’m thinking this might be an order of operations issue.

Is there something I’m missing to get this to work with docker? Do I need to modify the docker file to install pycryptodome as part of the container?

Any help is appreciated! Thank you!