Cannot install seafile server on my NAS

Hi there, I am trying to install a seafile server on my Seagate Goflex Home, which is based on an ARM v5te CPU (kirkwood). The server is now running on the ArchLinux ARM, I installed MySQL as the database. I donwloaded the Raspberry Pi version of tarball, extracted it and run the setup-seafile-mysql.sh as root. The script guided me through setting up all the databases and showed me the information for review. After pressing Enter, it reports the errors:

Press ENTER to continue, or Ctrl-C to abort

Generating ccnet configuration …

Traceback (most recent call last):
File “setup-seafile-mysql.py”, line 1461, in
main()
File “setup-seafile-mysql.py”, line 1414, in main
ccnet_config.generate()
File “setup-seafile-mysql.py”, line 810, in generate
if Utils.run_argv(argv, env=env_mgr.get_binary_env()) != 0:
File “setup-seafile-mysql.py”, line 84, in run_argv
env=env)
File “/usr/lib/python2.7/subprocess.py”, line 711, in init
errread, errwrite)
File “/usr/lib/python2.7/subprocess.py”, line 1343, in _execute_child
raise child_exception

OSError: [Errno 2] No such file or directory

Then I tried to install it by using sqlite, so I run setup-seafile.sh, it reported the error as the following:

./setup-seafile.sh: line 483: /home/seafile/seafile/seafile/bin/ccnet-init: No such file or directory

So, the question is: is this file is compatible with the ARM v5te architechture, all it’s due to some software problems? Thank you very much!