Cannot run Seafile Pro server 7.0.10 as non-root user

Hello,

After upgrading from 6.3 to 7.0.8 the issue I had with my search not working which is related to running Seafile as root.
When I try to run as non-root user I get the message that user ‘seafile’ is not the owner of ‘seafile-data’ and I should use the user root.

I have run chown -R seafile.seafile /home/seafile/shared/seafile-data and it completes without error but does not actually change afterwards when I run ls -l

The seafile-data folder is a network drive that is NTFS, is that what is causing the problem? and if so, any thoughts on how I can change the owner of that folder from root to seafile?

Thanks

man mount.ntfs
[…]
OPTIONS
Below is a summary of the options that ntfs-3g accepts.

   uid=value and gid=value
          Set the owner and the group of files and directories. The values are numerical.  The defaults are the uid and gid of the current process.

[…]
man mount.cifs
[…]
uid=arg
sets the uid that will own all files or directories on the mounted filesystem when the server does not provide ownership information. It may be specified
as either a username or a numeric uid. When not specified, the default is uid 0. The mount.cifs helper must be at version 1.10 or higher to support speci‐
fying the uid in non-numeric form. See the section on FILE AND DIRECTORY OWNERSHIP AND PERMISSIONS below for more information.
[…]