Cannot upload files over 200mb

Hello-

I cannot upload files in the web browser above 200mb.
Smaller files work fine.

In the seafile.conf I have tried under [fileserver]
max_upload_size=2000
max_download_size=2000

And also in same file under [httpserver]
max_upload_size=2000
max_download_size=2000

With restarts/reboots after each change.
I still cannot upload files larger than 200mb via the web console (seahub)

Here is my nginx config if helps

server { listen 443 ssl http2 default_server; listen [::]:443 ssl http2 default_server; server_name www.example.com;
gzip off;
ssl on;
ssl_certificate /etc/nginx/ssl/cert.pem;        # path to your cacert.pem
ssl_certificate_key /etc/nginx/ssl/key.pem;    # path to your privkey.pem
ssl_session_timeout 1d;
ssl_session_cache shared:SSL:50m;
ssl_session_tickets off;

ssl_protocols TLSv1.1 TLSv1.2;
ssl_ciphers 'ECDHE-ECDSA-AES256-GCM-SHA384:ECDHE-RSA-AES256-GCM-SHA384:ECDHE-ECDSA-CHACHA20-POLY1305:ECDHE-RSA-CHACHA20-POLY1305:ECDHE-ECDSA-AES128-GCM-SHA256:ECDHE-RSA-AES128-GCM-SHA256:ECDHE-ECDSA-AES256-SHA384:ECDHE-RSA-AES256-SHA384:ECDHE-ECDSA-AES128-SHA256:ECDHE-RSA-AES128-SHA256';

ssl_prefer_server_ciphers on;

OCSP Stapling

ssl_stapling on;
ssl_stapling_verify on;
ssl_trusted_certificate /etc/nginx/ssl/rootandinter.pem;
resolver 8.8.8.8 8.8.4.4 valid=300s;
resolver_timeout 5s;

Key exchange

ssl_dhparam /etc/nginx/ssl/dhparam4096.pem;
ssl_ecdh_curve secp384r1;

other settings

proxy_set_header X-Forwarded-For $remote_addr;
server_tokens off;
proxy_buffering off;

location / {
	proxy_pass         http://127.0.0.1:8000;
	proxy_set_header   Host $host;
	proxy_set_header   X-Real-IP $remote_addr;
	proxy_set_header   X-Forwarded-For $proxy_add_x_forwarded_for;
	proxy_set_header   X-Forwarded-Host $server_name;
	proxy_set_header   X-Forwarded-Proto https;

	access_log      /var/log/nginx/seahub.access.log;
	error_log       /var/log/nginx/seahub.error.log;

	proxy_read_timeout  1200s;
	client_max_body_size 0;
}

location /seafhttp {
	rewrite ^/seafhttp(.*)$ $1 break;
	proxy_pass http://127.0.0.1:8082;
	client_max_body_size 0;
	proxy_connect_timeout  36000s;
	proxy_read_timeout  36000s;
	proxy_send_timeout  36000s;
	send_timeout  36000s;
}

location /seafmedia {
	root /home/user/haiwen/seafile-server-latest/seahub;
}

}

Also using Raspberry PI Stretch minimal image with fresh install of Seafile 6.2.3

Are you on local LAN or WAN? There is a time limit in Seafile which can cause this problems. Please see:

When users upload files in the web interafece, file server assigns an token to authorize the upload operation. This token is valid for 1 hour by default. When uploading a large file via WAN, the upload time can be longer than 1 hour. You can change the token expire time to a larger value.

[fileserver]
#Set uploading time limit to 3600s 
web_token_expire_time=3600

In seafile.conf (https://manual.seafile.com/config/seafile-conf.html)

Seems to be some kind of network issue. I don’t think it’s a Seafile setting.
I disabled SSL and uploaded over HTTP and then the upload fails where intermitant. I did notice the speeds were double (7MB/s) then HTTPS. After enabling HTTPS again I tried to upload a bunch of times. A few times I see at the top a pop up that says something like “Check network connection, refresh” I’m not sure where to go from here…