Can't change Library/File history - Seafile CE 6.2.5

Hello Seafile community, I need your help and advice :slight_smile:

I’m running Seafile CE 6.2.5 server as backup solution in my company and it works really great, so kudos to Developers for making such a great product.

Anyway I’m not the original admin who deployed Seafile hence all of the original configuration is not done by me. My problem lays with File history which I cant change from keep full history to something more reasonable like maybe keep_days = 90.

I’m planing an upgrade to Seafile CE 6.3.2 and after upgrade finishes I plan to run a GC to purge trash. Since history is originally set to full and I cant change it now GC will probably fail to delete anything or it will not delete enough :slight_smile:

Originally keep_days = XY is configured in seafile.conf but users were allowed to change Library history settings and for some reason in this setup every new library created was set to Keep Full History by default. So I have XY users with XZY Libraries and all of them are set to Keep Full History. Not really great for my storage. :frowning:
Now I want to change history for already created libraries and obviously for all new that will be created to lets say 90 days. When i configure keep_days = 90 in seafile.conf and ENABLE_REPO_HISTORY_SETTING = False (NOTE: For some reason I need to Uncheck this option in System Admin Web panel otherwise it will not be configured even when it is defined in in and restart the seafile server i get these results: Users cant change History anymore but History for all users and all libraries are still set to Keep Full History (I can see all the files in trash or history that are older than 90 days). Also every newly created library also gets set to Keep Full History.

I have tried,

  1. Seafile server process restart
  2. Complete server restart
  3. Disabling history (keep_days = 0)
  4. Using different values for history length

and nothing works. History is always set to Keep Full History. I have also checked Seafile DB to see is Keep Full History hard-coded in DB for some reason but I cant find it.

Weird thing is that I have a test environment which I deployed from scratch and on test environment everything works as expected. My test system runs Seafile CE 6.3.2 and it has only 10 users with maybe 15 GB of test data.

Did anyone experience something like this ? Any Ideas on how I could resolve this issue?

Thanks in advanced for every help you provide.


Well upgrade to Seafile CE 6.3.2 has resolved my Can’t change history problem.

Hence this topic is resolved.