Can't connect from client - Credentials were not provided

Hi !

Just reinstalling my seafile server because I did some mistake that make the client unable to work properly.
I work with seafile behind apache with HTTPS on ubuntu 14.04 using let’s encrypt.
Using web interface, I can go on my server without any problem, but with the client I can’t connect to the server with a french “Connection Impossible”;

No error message server side but client side yes, I have:

[07/31/17 13:26:24]request failed for https://file.lecnet.fr/api2/account/info/: {“detail”:“Authentication credentials were not provided.”}

Here is my apache conf for this subdomain

<VirtualHost *:80>
        ServerName file.lecnet.fr
        DocumentRoot /var/www
        RewriteEngine on
        RewriteRule / https://file.lecnet.fr/
RewriteCond %{SERVER_NAME} =file.lecnet.fr
RewriteRule ^ https://%{SERVER_NAME}%{REQUEST_URI} [END,NE,R=permanent]
</VirtualHost>
<VirtualHost *:443>
        ServerName file.lecnet.fr
        DocumentRoot /var/www
        Include /etc/apache2/sites-available/ssl_conf
        Alias /media /home/lecomteg/lecfile/seafile-server-latest/seahub/media
        <Location /media>
                Require all granted
        </Location>
        RewriteEngine On
        ProxyPass /seafhttp http://127.0.0.1:8082
        ProxyPassReverse /seafhttp http://127.0.0.1:8082
        RewriteRule ^/seafhttp - [QSA,L]
        SetEnvIf Request_URI . proxy-fcgi-pathinfo=unescape
        SetEnvIf Authorization "(.*)" HTTP_ATHORIZATION=$1
        ProxyPass / fcgi://127.0.0.1:8003/
        CustomLog /var/www/vhosts/prod/panel.lecnet.fr/logs/file.log combined
        ErrorLog /var/www/vhosts/prod/panel.lecnet.fr/logs/file_error.log
</VirtualHost>

For me there is a problem with apache or let’s encrypt, else I would have server side errors…

Edit:

When I try to connect a client to my account, on my seafile web page on my linked devices I can see my computers. Which means that they’re seen and linked to the account.

Atm letsencrypt used a single certificate for all my subdomain but the folder where the cert is, is named with another subdomain. I tried to force certbot to create a certificate for seafile but it doesn’t seem to chnge anything.

Edit 2:

I followed again documentation for the configuration and it seems that I have exactly the same config (following deploying with mysql, then seahub with apache, then https on apache).

Found some django post that speak about this problem:

https:// python - Django Rest Framework - Authentication credentials were not provided - Stack Overflow
and this one

but they doesn’t help: the first one has 2 solution: one that concerns wsgi that I haven’t and another one that concern django framework that I don’t know at all that’s why I can’t apply it.

the second one didn’t help either, I tried to restart seafile, but also to empty cache and it didn’t work. I even tried to reboot server without any imrpovement.

I don’t see at all what I did wrong or I don’t find any clue about what can be the problem.

Edit 3:

Is there a apache config to check for example a redirect from http to https that may loose request body ? If yes, what I’ve to look for ?