Can't create download link from client (Mac)

Hi all,

I am not able to create download links from the sync’d files on my machine. I can do it from the WEB console, and even from the client if I use the Cloud File Browser… so I know all the server settings work… it just seems to be the client…

it is MacOS and on Catalina… not sure if I need to give permissions to the client (disk/folder…)

any help would be great!!

Hey all?? Any feedback?? I would really like to be able to use the function??

Hi Brett,
I guess no one answered your question because you didn’t provide a great deal of information.
You say:

What does that mean? Don’t you have the menu in the context menu? Does the client throw an error? Is the link dysfunctional, …

Also: What have you tried to fix the problem yourself?

You know, the better your description, the more inclined the community members are willing to help.

And no: No need to give permission.

ok… sorry if there wasn’t enough info…

basically I have set everything up in docker. I front-end with Traefik (reverse proxy) for SSL and friendly names etc… when I right click a file, None of the Seafile Context menus work. They are there, but nothing happens. If I click “Get Seafile Download link” nothing happens, and the same goes for, Version History and Lock this file.

I have tried uninstalling and re-instllig the client. I have tested that this works outside of the Mac Client. I can create links on my phone/iPad and also from the web client and from within the Cloud File Browser on the client. so it seems to be an integration within MacOs. I am on Catalina 10.15.2. if there are some logs or something that you need please yell out… happy to provide any more answers that I can… not sure what else is needed??