Can't donwload images

The title basically says it all. I can’t download any image (tried with jpg) files from my seafile server, getting a 404 Not Found when I try. Any other type of file (tried with md and mp4) works fine, also upload works. I can also preview images in browser without a problem, but previewing them in an android app gives me black screen. Here is a video showcasing the problem: Screen Recording 2021-08-13 at 07.57.14.

I am running seafile-server-8.0.5-buster-armv7l on my raspberry pi behind cloudflare and nginx proxy configured with Nginx Proxy Manager as described here: "Nginx Proxy Manager" causing failure when uploading files.

I would appreciate any help in solving this and can provide any other info, logs or whatever.

Thank you all.

I suspect a parameter in your configuration is off.

Use the browser console to find out more about what is going on and, in particular, which request URL Seafile uses when accessing images.

1 Like

Thanks for the response. I’ve checked and see nothing unusual. Here are the screenshots, first one is 404 for the jpg and the second one is getting the md file which is working. Maybe you can spot something?

Edit: just to be clear, I have no problem displaying the thumbnail of the image in browser, what fails is the download (can be seen in video).

What makes it weird is that if some config parameter was off I suspect all files would fail the download.

I’d say this is odd:

That should be jpg.

Check the location in the response header of the 302 response.

1 Like

Here it is:

I think you are onto something, any idea what exactly might be wrong?

Thanks a bunch for helping me:D

This is the output on my test system:

I’d say your problems are a thing of the past when disabling cloudflare - the use of which is really something you should mention in your problem description.

Sorry for the misunderstanding. Im pretty sure I did mention cloudflare in the first post: ... on my raspberry pi behind cloudflare and nginx proxy .... Might be a bit unnoticeable so sorry about that.
However disabling cloudflare did not fix it:

Im suspecting it might be the nginx proxy, like I said I configured it according to the solution on this post: "Nginx Proxy Manager" causing failure when uploading files.

Is there anything wrong with that?

I figured it out.

Nginx Proxy Manager has a setting Cache Assets which must be turned off!
Screenshot 2021-08-13 at 12.30.31

Thanks for helping me.

Sorry, my bad!! Of course, it is there. I just didn’t see it. Big apologies.

Amazing! Thanks for sharing this here.


1 Like