Can't upload files https on Windows

I am running the community edition on Windows.

When I try to upload a file, the progress bar doesn’t go anywhere. When I cancel the upload, I get the “Failed to get Upload URL” error.

I have changed settings countless times in the ccnet.conf, seafile.conf and seahub_settings.py I have verified an all my ports are open.

ccnet.conf:

[General]
USER_NAME = my-seafile
ID = 0372689b75fa5912df97f7acf27164bf21a3bfb6
NAME = my-seafile
SERVICE_URL = https://mydomain[Network]
PORT = 10001

[Client]
PORT = 13418

seafile.conf

[database]
type = sqlite

[network]
port = 12001

[fileserver]
port = 8082

[seahub]
port = 8001
fastcgi = false

[fileserver]

Set maximum upload file size to 500M.

max_upload_size=500

Set maximum download directory size to 500M.

max_download_dir_size=500

[quota]

default user quota in GB, integer only

default = 5

seahub_settings.py

SECRET_KEY = ‘6coh7nDUeBgsqplb8Ypm0MjxbNJKlcV+LWv+KcnqJfhrb7X99t2t7goAAACnq9dl/v///4j8ZAD5gEAABAAAAPH6QAAAAAAA4S4AAJIfAAAAAAAAsFBzAGhdcwAwZ4IAgBBQd3C5ggAAAAAAapqLE6jPggDI/GQAWYhAAPg3cwBEAAAAAAAAAI/9QAAAAAAAAAAAAMj8ZAB/lEAAjABBAA==’

HTTP_SERVER_ROOT = ‘http://mydomain:8082

I have it working except file upload and download. Please help thanks!

I changed my seahub_settings.py to have:
FILE_SERVER_ROOT = ‘https://mydomain/seafhttp

Needless to say no change. I also checked the administration and the settings are the same. This is definitely a problem with Seafile. If I don’t get some help I’ll move onto another program that works.

I’ve been through every thread regarding file upload issues and none of the fixes worked. I have to use https. It seems that it works on regular http.

Maybe the problem lies in the configuration of your webserver (nginx? Apache?).
You should post its configuration, too.

I’m not using Apache or nginx. I’m using IIS.
https://www.weavweb.net/2015/06/07/seafile-https-sync-on-windows-server-2012r2-step-by-step/

I solved the issue. The seafile.conf had the seahub port defaulted to port 8001. Although the port was open and accessible, the file upload didn’t work.

When I changed the port to 8000 (this is the default port from the older version as per the documentation), the file upload worked.