Ccnet try to listen on 10001 with seafile 7.1

Hello,

Since seafile 7.1 I saw that the ccnet try to listen on the port 10001. I think that it’s probably a regression because on seafile 7.0 this port wasn’t used. I’ve tried to customise this parameter in the ccnet config file:

[Network]
PORT=10003

But it look like that it’s completly ignored.

It’s a big issue because on case of a server with some other service we have a conflict with postsrsd service.

What reason do you need this? I had actually been using this port for a long time too, because a user could not update to a client higher than version 3.0 due to an old computer architecture (macOS 32 bit). Otherwise, these two lines can simply be deleted completely from the config file, if I’m not mistaken.

Maybe I wasn’t explain exactly the issue. With seafile 7.0 ccnet wasn’t listening on this port. It’s only with the version 7.1 that ccnet was listening on this port even if theses two lines are not in the config file.

In that case, it indeed seems to be a bug @daniel.pan

@daniel.pan This bug is still present in 7.1.4 Pro

This will be fixed in the next version.

This bug effectively killed the possibility of multi Seafile instances on one server. Each instance tries to bind on 10001 port, which creates conflict.

As far as I know, there is no workaround. You cannot skip this binding, nor you can change port 10001 to something else. It is all hard-coded in ./seafile/bin/ccnet-server binary.

This bug is nasty. Just do not upgrade to 7.1 if you want to run multi-instances.

WORKAROUND:

If you accidentally upgraded to 7.1, downgrade to 7.0 is possible, but keep this in mind:

  • Seafile 7.0 requires Python/2, while 7.1 runs on Python/3
  • file gunicorn.conf.py needs to be renamed back to gunicorn.conf
  • memcached caching must be disabled because once pylibmc is upgraded, you cannot go back

I can confirm that this is fixed in 7.1.5 Pro