Centos 7 - apache (https) - fastcgi - showing Apache Test Page

Hello. I have installed SeaFile server under CentOS 7 using apache and mysql , correct setup it to use https and it was working for 2 months with no problem, until last week, for some reason that I could not figure it out yet my SeaFile server stopped to work, the client can not connect to the https://myserver any more. When I tried to access it via browser the initial page is the Apache Test Page and not the SeaFile login page anymore, and the weirdest thing is that I just made a fresh install in another CentOS7 server using the same procedure (official manual from Seafile website) and also does not work, it goes direct to Apache Test Page, and not to the login page. Selinux is disabled and firewall is OFF. Any ideas? Thank you all.

Nobody is having the same problem? is the server working ok?

No reply?? I dont believe I am the only one that has this issue!! I did a clean install and I got the same error, what is going on?? Thanks