Charset in textfile preview

I’m using seafile pro 5.1.8, but this also happens in pro 6.0.8.
I created a textfile under Windows 10 (German) and wrote a word with umlauts (“Mühlenstraße”) into it:

Then I copied the file into my shared seafile directory. When I logged into the web interface and opened the textfile in my web browser, I saw chinese characters instead of the umlauts and the character set in the menu was “gbk”. I selected “utf-8” from the menu, but the view didn’t change:

I edited the text, selecting “utf-8” from the charset menu, and entered the same word:

I saved the file and opened it from the synchronized directory. It now looks like this:

Can the default charset be defined somewhere in seafile?

You can change the settings via add the following config items to

FILE_ENCODING_LIST = ['auto', 'utf-8', 'gbk', 'ISO-8859-1', 'ISO-8859-5']
FILE_ENCODING_TRY_LIST = ['utf-8', 'gbk']

Great! This works.
Thanks for your support.

Is it recommended to set this option by default?