Client is uninstallable on Debian buster


#1

Hi,

$ lsb_release -a
No LSB modules are available.
Distributor ID:	Debian
Description:	Debian GNU/Linux testing (buster)
Release:	testing
Codename:	buster

I realise that currently you Debian 7 [wheezy] (end-of-life May 2018), Debian 8 [jessie] (end-of-life June 2020) and Debian 9 [stretch]; I’d appreciate it if you could look into also support buster.

Otherwise the problem is:

$ sudo apt-get install seafile-gui
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 seafile-gui : Depends: libevent-2.0-5 (>= 2.0.10-stable) but it is not installable

Support timelines are from https://wiki.debian.org/LTS


#2

Just use the package available in the Debian repositories without any additional repositories.


#3

I am. It fails.
The only repositories configured are Debian and Seafile.


#4

You need to remove the Seafile repository, too.


#6

What should that post be? There is the advice from the official debian seafile maintainer that he have to use the debian repo instead of the seafile company’s one. It’s about Debian, not Apple.


#8

Which version did you use?
Debian Buster should include 6.1.8-1, which works (on all my systems).
Debian Sid already has 6.2.5-1, but that doesn’t work right now.