Client not working anymore in OSX

Hey guys,

I have a big problem that I just can’t understand and that I just can’t solve.

I’m running a rather old machine: It’s an iMac late 2006 with OSX 10.7.5.

So far I have been using the OSX Client in Version 5.0.7 without any problems at all. Now I decided to update to the newest version 5.1.4 and that’s when all went downhill. The installation went by without any problems. But when I wanted to start the client, the icon appeared in the dock as if it would start, then it would disappear but nothing would happen afterwards. There is no sea file window that opens as it usually would and I also don’t get an icon in the task bar. When I then try to delete the app to uninstall it, the Finder tells me that it can’t delete it because it is in use, although there is nothing of it onscreen. When I reboot my machine, I can delete and uninstall it. I then reinstalled the version I used before without problems 5.0.7 but now, it behaves the same way, the 5.1.4 version did: The icon shortly appears in the dock, then disappears and then there is nothing but when I try to delete the app, Finder tells me that it is in use… I tried uninstalling and reinstalling, rebooting and everything several times but it just won’t work anymore.

I really hope that somebody here can help me because I’m heavily depending on a working sea file access for my workflow.

You can try completed uninstall the app by:

  1. Open Activity Monitor
  2. Search for “Seafile Finder Sync”, “seaf-daemon” and “Seafile”. Stop all of them.
  3. Remove ~/.ccnet and ~/Seafile.

Then reinstall the App and resync libraries.

Hi Daniel,

thanks for the help but it didn’t solve the problem. As you wrote, I stopped the processes, removed the folders and reinstalled the version 5.0.7 that used to work before.

When I start the app, it asks me where to put the sea file folder, this is as expected since I deleted it before. But after that the same behavior takes place: The dock icon disappears and nothing happens. Usually at this point, a window should pop up where I’m asked about the server I want to connect to. But this doesn’t happen. When I then look at the Activity Monitor the processes seaf-daemon and Seafile are running but not “Seafile Finder Sync”. When I now stop these two processes, I can move the app into my trash but when I want to empty the trash it says, that the sea file app is still in use and the trash can’t be emptied. I have to restart my computer to be allowed to empty the trash and remove the sea file app from my computer.

I have no idea, how this came up. My system has been running flawlessly since I made a fresh install in Mai. And I haven’t changed much since then. The only thing was that I installed Dropbox lately but that was already two weeks ago and both services Dropbox and Seafile have been running side by side without problems so far. Since I don’t really use Dropbox I removed the client again from my computer to try out, if that helps the problem I have with sea file but that didn’t help either.

Have you checked the log file ~/.ccnet/logs/seafile-applet.log?

Here is what I just did:

Complete uninstall of Seafile including deletion of .ccnet and Seafile folders.
Fresh reinstall of Client 5.1.4
Started the app: Asks for place for Seafile folder, then described error happens: Dock icon disappears and then nothing.

Content of the specified log file: None, the log file is empty.

But the app seems to be running somewhere: In the activity monitor deaf-daemon and Seafile show up each uses 4 threads but 0% CPU power.

Ran into this exact same issue on Mac OS 10.12. At first I thought it was because it’s in beta but I guess that might only be part of the issue.

Have you been able to solve the problem? It still is not working for me anymore.

I’m sorry the problem is hard to reproduce for us and we are not able to solve it yet.

It might be something wrong with the server? I don’t use the OSX client but it happened once to windows client that it just froze and closed down itself due to a invalid certificate at the server end. Replaced the certificate and problem fixed.

Well at the same time that I have updated the the Client I have also installed my server from scratch (6.0 on a Raspberry Pi). But the client should just open the window where it says that it can’t find the server anymore and ask for a new server. That’s at least what happens in Windows.

You should also not forget, that I have deleted everything you mentioned (./ccnet, /seafile) and when I reinstall the client it should be like a fresh install.

I reinstalled the OS on the client and everything worked fine after that. However reinstalling the OS is hardly a good fix.

Thanks for yout insights. However this is not a viable solution for me. I had just reinstalled my whole system (Dual Boot Osx and Windows on one Harddrive) in Mai. I don’t have two days of spare time to reinstall everything again. My guess is that the newest version of the client has faulty files which reside in the system even after uninstalling. Maybe the devs could give advice onwhat files to delete to completely remove seafile as is it has never been in the system.

I just noticed something else. Since I tried to install client 5.1.4 unsuccessfully, my Sophos Anti-Virus is not able to update anymore. I get an error message that the update is unsuccessful. It seems 5.1.4 not only messes up itself but also other programs.

@HansMeiser It’s not uncommon, unfortunately, for MacOS installation programs to mess up for eachother. If one installd doesn’t finish the next one won’t succeed.

Reboots work, but a quick fix is to type “killall -9 installd” in a Terminal window. It will quit any lingering install-processes.

Are you using Sophos Home? What OS X Version are you using, My issues all started when I started beta testing Mac OS 10.12.

Nvm I see you are running 10.7.5

I’m using Sophos Endpoint Security and Control.

I got the same problem under macOS Sierra and the Client 5.1.4 (5.1.1 does not work too).
I did a complete uninstall of the old client like daniel.pan recommended but it does not work - still no icon in the menu bar. The logs are not very helpful I think:

applet.log

[09/19/16 09:09:30]starting seaf-daemon: (“-c”, “/Users/xxx/.ccnet”, “-d”, “/Users/xx/Seafile/.seafile-data”, “-w”, “/Users/xx/Seafile”)
[09/19/16 09:09:31][Rpc Client] connected to daemon
[09/19/16 09:09:31][Rpc Client] connected to daemon
[09/19/16 09:09:31][MessageListener] connected to daemon
[09/19/16 09:09:32]Unable to get config value download_limit: Config not exists
[09/19/16 09:09:32]Unable to get config value upload_limit: Config not exists
[09/19/16 09:09:33][Rpc Client] connected to daemon

ccnet.log

[09/19/16 09:09:29] ccnet-daemon.c(193): starting ccnet client 5.1.4
[09/19/16 09:09:29] …/common/session.c(132): using config file /Users/xx/.ccnet/ccnet.conf
[09/19/16 09:09:29] …/common/session.c(455): socket file exists, delete it anyway
[09/19/16 09:09:29] …/common/session.c(484): Listen on /Users/xx/.ccnet/ccnet.sock for local clients
[09/19/16 09:09:29] …/common/session.c(290): Update pubinfo file
[09/19/16 09:09:30] …/common/session.c(398): Accepted a local client
[09/19/16 09:09:30] …/common/session.c(398): Accepted a local client
[09/19/16 09:09:30] …/common/session.c(398): Accepted a local client
[09/19/16 09:09:30] …/common/session.c(398): Accepted a local client
[09/19/16 09:09:31] …/common/session.c(398): Accepted a local client
[09/19/16 09:09:31] …/common/session.c(398): Accepted a local client
[09/19/16 09:09:31] …/common/peer.c(943): Local peer down
[09/19/16 09:09:31] …/common/peer.c(943): Local peer down
[09/19/16 09:09:31] …/common/session.c(398): Accepted a local client
[09/19/16 09:09:31] …/common/session.c(398): Accepted a local client
[09/19/16 09:09:31] …/common/session.c(398): Accepted a local client
[09/19/16 09:09:33] …/common/session.c(398): Accepted a local client
[09/19/16 09:09:33] …/common/session.c(398): Accepted a local client

seafile.log

[09/18/16 18:09:43] seaf-daemon.c(548): starting seafile client 5.1.4
[09/18/16 18:09:43] seaf-daemon.c(550): seafile source code version 075202c2f86a8413068f2c3cf160e91aee352283
[09/18/16 18:09:43] …/common/mq-mgr.c(60): [mq client] mq cilent is started
[09/18/16 18:09:43] …/common/mq-mgr.c(106): [mq mgr] publish to heartbeat mq: seafile.heartbeat
[09/18/16 19:49:08] Disconnected from daemon
[09/19/16 09:09:30] seaf-daemon.c(548): starting seafile client 5.1.4
[09/19/16 09:09:30] seaf-daemon.c(550): seafile source code version 075202c2f86a8413068f2c3cf160e91aee352283
[09/19/16 09:09:30] …/common/mq-mgr.c(60): [mq client] mq cilent is started
[09/19/16 09:09:31] …/common/mq-mgr.c(106): [mq mgr] publish to heartbeat mq: seafile.heartbeat

btw, immediately after the the macOS Sierra Update the client icon was visible on the menu bar, but after the client update it was gone.

I got an iMac and a MBA with the same problem, it is pretty annoying.

If you need any further information please let me know.

EDIT:
When I open the seafile package and manual start the seafile-applet I get the main seafile window and the seafile icon appears on the menu bar. It looks pretty fine, but the GUI does not accept any input.

The terminal output looks like that:

/Applications/Seafile\ Client.app/Contents/MacOS/seafile-applet ; exit;
[warn] kq_init: detected broken kqueue; not using.: No such file or directory
logout
Saving session…
…copying shared history…
…saving history…truncating history files…
…completed.
Deleting expired sessions…16 completed.

[Prozess beendet]

Maybe this bug is the reason.

No activity on the client via GitHub except for 11 days ago…:confused:
@daniel.pan Considering Sierra got released today I’d imagine you will have a bunch of upset clients here shortly…

We don’t know if it a Sierra issue or our client issue and whether it will be automatically solved when Sierra is officially released.

Btw, please don’t always talking in a pushing way.

I have the reply form one customer of us, that everything is working with the 5.1.4 client and the official macOS Update.

Has anyone here a update on this?