Confused - Help?

I’ve installed seafile server on Linux Mint using the guide on your website (I think the guide was for Ubuntu). It was titled "deploying seafile with SQLite). After the setup was finished and I went to test the server it wouldn’t work. Towards the end of the guide it gave instruction to change the port to 8001. I followed it. After changing the port to 8001 it worked… This angers me because I spent a lot of time (like maybe 15 minutes) trying to figure out why it wasn’t working. And I still don’t understand why port 8001 works and 8000 wouldn’t. Port 8000 isn’t blocked on my router. Maybe I should just be thankful that it works.

Maybe port 8000 has been taken by another program? You can check it with the command netstat -nltp |grep 8000 .

Thanks for the reply lins05. Yes…port 8000 is free. I’m not worried about it.

Try changing it to 8001 again, restart seafile and seahub and check with

netstat -tulpn | grep 8001

if seahub is really using this port. If this does not work, please show us your apache/nginx config.

Ill try to. It might be a while though.

Here’s the output:

tcp 0 0 0.0.0.0:8001 0.0.0.0:* LISTEN 4351/python2.7

In an attempt to get my autoboot to work i changed the port to 8000 and it’s working on that port too now.

On what “that” port? 8000? I thought it worked on 8000 before?

Anyways, your configuration seems to be wrong at some point. It should not reflect python on

tcp        0      0 0.0.0.0:8001            0.0.0.0:*               LISTEN      4351/python2.7

but your webserver:

tcp        0      0 0.0.0.0:8001            0.0.0.0:*               LISTEN      9494/nginx   

My guess is you configured seafile correctly but not nginx/apache. Or you did but forgot to reload config after you edited it.

Anyways, please mark the thread as solved when your problem is gone.

I did not work on port 8000 when I initially set it up. It works on both 8000 and 8001 now.

I’ll mark it as solved.