Copied entire ../seafile to a new directory and ./ won't launch

Hi all

I’ve been happily running my own seafile server since 2016 and recently I’ve moved (using mv) my seafile directory from /home/seafile to /opt/seafile. I did this in preparation for upgrading to 7.0. I have modified my …/seafile/ccnet/seafile.ini directory to mirror the changed location. I’ve also updated my nginx config file for this change. ./ starts no problems. Is there any other config files i need to update?

I’m not seeing any particular errors in the seahub.log, i’m only getting an info message about seafevents.db. What i get in the command line is as follow:

LANG is not set in ENV, set to en_US.UTF-8
LC_ALL is not set in ENV, set to en_US.UTF-8
./ line 231: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)
Starting seahub at port 8000 …
Error:Seahub failed to start.

My current version is seafile server pro 6.3.9 running on Debian 9.9.

Any Help would be hugely appreciated :slight_smile:

File system rights sat correctly? You could add DEBUG=true to your to get more information.

1 Like

Yep, i believe, so It was set as 755, but i’ve tried again at 777 with no changes. With root as owner. I’ve tried setting the debug flag in as per your suggestions but to no avail. Nothing has been written seahub.log file since this problem began. Looking through the other logs, there is some errors in seafile.log & in controller.log but they were occurring long before i had this issue problem anyway. Any other suggestions?


After having anther closer look at my i realized in my fault finding i introduced a typo.
Now that’s resolved, i’m able to start seahub but i’m getting several errors in my seahub.log, all along the same line of this.

[ERROR] django.request:135 handle_uncaught_exception Internal Server Error

I can attach the complete section of log that is output when starting seahub, but its mostly similar to the above and says

OperationalError: no such table: api2_tokenv2
OperationalError: no such table: notifications_notification

The other thing i changed which i believe got seahub working again was changing the pids_dir under gunicorn.conf

pids_dir = ‘/home/seafile/pids’
pids_dir = ‘/opt/seafile/pids’

I’ve also read this might be related to my memcached settings in, however i’ve had memcached commented out of this file for a while now, before the problems began, however i have got memcached installed.

Would this be related to my issues?

Thanks very much.

Try to update, even though there isn’t any avaiable. Hopefully, this will fix it.

i did run an update from 6.3.9 to 6.3.14 (following the normal procedure and running the minor upgrade script) and unfortunately no change. I Could try running one of the other upgrade scripts?