Creation of an admin account is not working (FreeNAS jail)


i have just installed Seafile in a FreeNAS 11.2 jail (pkg install seehub) and it was installed with all dependecies without errors, after that i run /usr/local/www/haiwen/seafile-server/ to complete the setup which also finish without an error.

The configuration did not create an admin user so i have to run /usr/local/www/haiwen/seafile-server/ in order to create it, but this script comes back with these errors:

root@seafile:/usr/local/www/haiwen/seafile-server # ./
E-mail address:
Password (again):
Traceback (most recent call last):
File “/usr/local/www/haiwen/seafile-server/seahub/”, line 10, in
File “/usr/local/lib/python2.7/site-packages/django/core/management/”, line 364, in execute_from_command_line
File “/usr/local/lib/python2.7/site-packages/django/core/management/”, line 356, in execute
File “/usr/local/lib/python2.7/site-packages/django/core/management/”, line 283, in run_from_argv
self.execute(*args, **cmd_options)
File “/usr/local/lib/python2.7/site-packages/django/core/management/”, line 330, in execute
output = self.handle(*args, **options)
File “/usr/local/www/haiwen/seafile-server/seahub/seahub/base/management/commands/”, line 150, in handle
User.objects.create_superuser(email, password)
File “/usr/local/www/haiwen/seafile-server/seahub/seahub/base/”, line 71, in create_superuser
u = self.create_user(email, password, is_staff=True, is_active=True)
File “/usr/local/www/haiwen/seafile-server/seahub/seahub/base/”, line 61, in create_user
return self.get(email=email)
File “/usr/local/www/haiwen/seafile-server/seahub/seahub/base/”, line 99, in get
raise User.DoesNotExist, ‘User matching query does not exits.’
seahub.base.accounts.DoesNotExist: User matching query does not exits.

Can anybode help me on this issue?

Thanks in advance!

to create the admin user the first time you have to run seafile in this way,
go to seafile-server-latest and :

./ start # Start Seafile service
./ start <port>  # Start seahub website, port defaults to 8000

when you run ./ start you will be asked for an email address for the admin and a password

Thanks for the information, i am now getting a step further but i still get an error:

root@seafile:/usr/local/www/haiwen/seafile-server-latest # ./ start

LC_ALL is not set in ENV, set to en_US.UTF-8
Starting seahub at port 8000 …

It’s the first time you start the seafile server. Now let’s create the admin account

What is the email for the admin account?
[ admin email ]

What is the password for the admin account?
[ admin password ]

Enter the password again:
[ admin password again ]

Error happened during creating seafile admin.

python2.7: can’t open file ‘/usr/local/www/haiwen/seafile-server/seahub/thirdpart/gunicorn’: [Errno 2] No such file or directory
Error:Seahub failed to start.
Please try to run “./ start” again

it’s up to you to set the email address and password you want

“LC_ALL n’est pas défini dans ENV, mais sur en_US.UTF-8”
this is not a mistake it’s a problem the language definition i see for years and seafile works fine .it can be fixed by modifying the file /seafile-server-latest/ from line 225 to 232 …

for the mistake

python2.7: impossible d’ouvrir le fichier ‘/ usr / local / www / haiwen / seafile-server / seahub / thirdpart / gunicorn’: [Errno 2] Aucun fichier ou répertoire de ce type

we would have to see the seafile log files: seahub.log, seafile.log, seafevents.log, seahub.init.log, seafile.init.log, controller.log, ccnet.log. to help you

The script tries to access the gunicor file but this doesn’t exist, can install it somehow?

gunicorn is installed during the installation of seafile automatically .it’s weird that it may not have been installed maybe a permission problem or right on a folder .