.csv file does not open in OnlyOffice

Hi. I’m running OnlyOffice in Seafile Professional 8.0.10 and everything works fine. But I noticed that e.g. only docx was added to the ONLYOFFICE_EDIT_FILE_EXTENSION config item as default and not doc, so I added also ‘doc’ and now I can edit also doc files. However, I also added ‘csv’ which is supported by OnlyOffice, but when I click on a csv file, it just opens in the Seafile viewer and not in OnlyOffice. Since doc files work after I added it, I know the config file is correct.

Here is the relevant part from my seahub_settings.py:
ONLYOFFICE_FILE_EXTENSION = (‘doc’, ‘docx’, ‘ppt’, ‘pptx’, ‘xls’, ‘xlsx’, ‘odt’, ‘fodt’, ‘odp’, ‘fodp’, ‘ods’, ‘fods’, ‘csv’)
ONLYOFFICE_EDIT_FILE_EXTENSION = (‘doc’, ‘docx’, ‘ppt’, ‘pptx’, ‘xls’, ‘xlsx’, ‘odt’, ‘odp’, ‘ods’, ‘csv’)

Any ideas?


Is this what you’re looking for? Note that CSV is present here as well.

# Extensions of previewed text files.
TEXT_PREVIEW_EXT = """ac, am, bat, c, cc, cmake, cpp, cs, css, diff, el, h, html,
htm, java, js, json, less, make, org, php, pl, properties, py, rb,
scala, script, sh, sql, txt, text, tex, vi, vim, xhtml, xml, log, csv,
groovy, rst, patch, go"""

No, that is just the list of extensions that should open in the internal viewer. This is exactly what I don’t want. I tried removing ‘csv’ from TEXT_PREVIEW_EXT but csv files still don’t open in OnlyOffice. The only thing I get then is “Online view is not applicable to this file format”.

That’s a bummer. Is the OnlyOffice Desktop Editor a possible workaround for you in this case? It does connect to Seafile and offers you the option of opening the csv file in the spreadsheet.

No, that wouldn’t be an acceptable workaround. But I tried that already as well, but the same thing happens. Their desktop editor seems to be just a browser window opening the link the Seafile sends when trying to open the file.

It seems to me that Seafile is selectively ignoring the ONLYOFFICE_FILE_EXTENSION setting, like there would be an AND between that setting and an internal tuple. So sounds like a bug. Where can I make a bug report?


You might post a note on Seafile’s Github Issues forum.

You can also add a comment on the OnlyOffice Support site. They are also on Github. They do field questions about Seafile.

Thanks, I created a bug report. Issue #2491 for reference.