Datei Upload nicht möglich

System Infos:

OS: Windows Server 2016 Datacenter x64
Python 2.7.11

Ich habe Seafile nach der aktuellen WIKI installiert.
Es läuft so weit auch ganz gut, bis auf das Problem, das man weder lokal noch extern noch per APP Dateien hoch bzw. runterladen kann.

Inhalt der Logs:

CCNET
[04/13/20 22:27:23] …/common/session.c(132): using config file S:/seafile-server\conf\ccnet.conf
[04/13/20 22:27:23] …/common/session.c(418): Listen on 127.0.0.1 13418
[04/13/20 22:27:23] …/common/session.c(290): Update pubinfo file
[04/13/20 22:27:23] …/common/connect-mgr.c(515): Opened port 10001 to listen for incoming peer connections
[04/13/20 22:27:24] …/common/session.c(398): Accepted a local client
[04/13/20 22:27:24] …/common/session.c(398): Accepted a local client
[04/13/20 22:27:24] …/common/session.c(398): Accepted a local client
[04/13/20 22:27:24] …/common/session.c(398): Accepted a local client
[04/13/20 22:27:24] …/common/session.c(398): Accepted a local client
[04/13/20 22:27:26] …/common/session.c(398): Accepted a local client
[04/13/20 22:27:26] …/common/session.c(398): Accepted a local client
[04/13/20 22:27:27] …/common/session.c(398): Accepted a local client
[04/13/20 22:27:34] …/common/session.c(398): Accepted a local client

SEAFILE
[04/13/20 22:27:24] …/common/mq-mgr.c(54): [mq client] mq cilent is started
[04/13/20 22:27:24] listen-mgr.c(120): listen on port 12001 for block tranfer

SEAFSERV
[04/13/20 22:27:23] created “python.exe -V”, pid 7320
[04/13/20 22:27:23] seafserv/seafserv.c(63): starting ccnet-server …
[04/13/20 22:27:23] created “ccnet-server.exe -c “S:/seafile-server\ccnet” -f “S:/seafile-server\logs\ccnet.log” -F “S:/seafile-server\conf””, pid 7856
[04/13/20 22:27:23] seafserv/seafserv.c(466): ccnet server started
[04/13/20 22:27:24] seafserv/seafserv.c(334): trying to connect to ccnet-sever…
[04/13/20 22:27:24] seafserv/seafserv.c(360): connected to ccnet server
[04/13/20 22:27:24] seafserv/seafserv.c(90): starting seaf-server …
[04/13/20 22:27:24] created “seaf-server.exe -c “S:/seafile-server\ccnet” -d “S:/seafile-server\seafile-data” -l “S:/seafile-server\logs\seafile.log” -F “S:/seafile-server\conf””, pid 7240
[04/13/20 22:27:24] seafserv/seafserv.c(161): starting seahub …
[04/13/20 22:27:24] created “python.exe “C:\Cloud\seafile\bin…\seahub\manage.py” runwsgiserver host=0.0.0.0 port=8000 autoreload=False staticserve=False”, pid 4620
[04/13/20 22:27:24] seafserv/seafserv.c(560): [process monitor] started.

SEAFSERV-APPLET
[13.04.2020 22:27:23] applet/seafserv-applet.c(793): starting seafserv …
[13.04.2020 22:27:23] created “seafserv.exe”, pid 6280
[13.04.2020 22:27:26] applet/seafserv-applet.c(237): trying to connect to ccnet-sever…
[13.04.2020 22:27:26] applet/seafserv-applet.c(263): connected to ccnet server

SEAHUB
2020-04-13 22:27:26,006 [INFO] root:292 runwsgiserver starting server with options:
{‘adminserve’: ‘Deprecated’,
‘autoreload’: False,
‘daemonize’: False,
‘host’: ‘0.0.0.0’,
‘pidfile’: None,
‘port’: ‘8000’,
‘server_group’: ‘www-data’,
‘server_name’: ‘localhost’,
‘server_user’: ‘www-data’,
‘servestaticdirs’: True,
‘ssl_certificate’: None,
‘ssl_private_key’: None,
‘staticserve’: False,
‘threads’: 10,
‘workdir’: None}

Konfiguration im AdminPanel bezüglich der URLs

SERVICE_URL htxp://adresse.ddns.org:8000
FILE_SERVICE_ROOT htxp://adresse.ddns.org/seafhttp

Ich bin mit probieren und experimentieren echt am Ende und währe über Hilfe sehr dankbar.

Version 7.0.5?
Irgend nen Load-Balancer oder Reverse-Web-Proxy noch davor?
Wenn probiert wird, dann bloß nicht mit dem IE11.
Debug mal eingeschaltet?

Hallo, nur eine Vermutung:

  1. als Service_URL und File_Service_Root muss doch die gleiche Adresse inklusive Port angegeben werden oder?

D.h. der Port :8000 müsste noch hinter .org des File_Service_Root .

Ohne geht nur, wenn man einen Reverse Proxy nutzt. Dann müssen beide Adressen ohne Port sein.

Hallo,

Ich habe bei den Service und File URLs schon alle möglichen Kombinationen versucht, eine Verbindung baut er generell nur bei folgender Konstellation auf, sonst meldet er Server nicht gefunden.

SERVICE_URL htxp://adresse.ddns.org:8000
FILE_SERVICE_ROOT htxp://adresse.ddns.org/seafhttp

Wenn ich den Port 8000 beim Root mit setze, meldet er keinen Server gefunden.

Der Seafile befindet sich direkt auf dem WInSRV, auf dem sind alle benötigten Ports freigegeben, im Router ebenfalls. Proxy odg. werden nicht verwendet.

Seafile Version ist die aktuellste

Ah war auch glaube Mist von mir. Der Fileserver läuft ja sowieso über einen anderen Port.

Achso, ich hatte damals das Problem mit der Time Zone, also in der seahub_settings.py einmal folgende Zeile eintragen:

TIME_ZONE = ‘UTC’

Vielleicht hilft es ja, aber das selbe Probleme hatte ich vor Jahren auch schon. Ist nur so lange her.

PS. Falls es läuft und es mehrere Nutzer werden bzw. viele Daten, kann ich dir nur dringend memcached empfehlen, das ebschleunigt die Weboberfläche unglaublich (falls man sie braucht).

also die Variable heißt FILE_SERVER_ROOT nicht SERVICE, und bei mir ist die im Admin Panel gleich mit dem Eintrag in der seahub_settings.py. Eventuell mal in der seafile.conf gucken, ob sie richtig geschrieben ist.
die SERVICE_URL wird in der ccnet.conf eingetragen im Format SERVICE_URL = htxps://my.domain.tld
Ich verwende das ganze hinter nem Reverse Web Proxy wegen Let’s Encrypt, kann daher nicht sagen, ob in dem Fall noch der Port :8000 hinten ran gehört.

sobald ich in die seahub_settings.py etwas eintrage kann man die Weboberfläche nicht mehr öffnen.

Dann scheint aber etwas in der Datei oder so nicht zu stimmen.

Im Notfall Mal die Datei posten.

da steht nur der Secret Key drinn

so sieht meine Datei aus:

SECRET_KEY = “XXXX”
FILE_SERVER_ROOT = ‘htxps://my.domain.tld/seafhttp’
DATABASES = {
‘default’: {
‘ENGINE’: ‘django.db.backends.mysql’,
‘NAME’: ‘seahub-db’,
‘USER’: ‘xxxx’,
‘PASSWORD’: ‘xxxx’,
‘HOST’: ‘127.0.0.1’,
‘PORT’: ‘3306’
}
}

Also ich habe die Cloud noch einmal neu installiert unter einem anderen Laufwerk.

Der Fehler liegt im Detail:

die Einstellungen im Admin Panel angepasst in folgende:

SERVICE_URL htxp://adresse.ddns.org:8000
FILE_SERVICE_ROOT htxp://adresse.ddns.org:8082

Jetzt funktioniert der Upload.

Danke an alle die mit geholfen haben.

1 Like