Debian Testing Debs

Hello,
the current client for debian is linked against various libs/versions that are only part of the stable branch.

I know nobody using Debians Stable branch on a desktop… I run stable on my server, but all clients are testing. And this is what most people do… The dpkg rejects to install the deb in testing and insists in old versions of the libs.

As I do not believe the libs API changed soo dramatically I guess the deb is only build i a very unflexible way.

I addition the situation is not starting to get better by running de/com domain of seafile in fighting companies.

Regards Marc

I second that.

I have tried to run the Jessie debs on Stretch, and this resulted in seafile-daemon aborting with segfaults. Also the seafile-applet didn’t recognize the dead seafile-damon and still showed up like ok.

Rebuilding the debs solved this.

Please provide packages for Debian Stretch!

You can install the seafile client along with libssl1.0.0 from Debian jessie.

An effort for official Debian packaging of the Seafile Client packages is currently underway.

Is there a patch for libssl1.1 compatibility yet? Anyway, unfortunately seafile stopped working in Debian Stretch now, compiling with libssl1.0-dev succeeds but does not work (segfault in seaf-daemon).

I think this is due to our usage of some deprecated functions in libssl. I’ll check.

NB: seafile is working fine in Archlinux with libssl-1.0.0.

Hello!
Same issue for me in my recent Debian Stretch. Can’t sync any library. Segmentation fault. I can send logs if needed.

I also try to compile, (https://manual.seafile.com/build_seafile/linux.html ) but I didn’t be able, there was a problem compiling ccnet.

@woffs , how did you “rebuilt” the debs?

Thanks a lot

I fetched https://github.com/haiwen/seafile-debian-packging and looked into build.sh