Deleted file still remains on disk of the server

as my space is nearly at the limit i deleted a 5gb sized file from my library, in the webinterface it shows that the disk usage shrunk for 5gb, but the blocks are still on the disk, even if i run

what can i do?


Starting seafserv-gc, please wait ...
[11/27/17 10:05:58] gc-core.c(440): GC version 1 repo Meine Bibliothek(*repo-id*)
[11/27/17 10:05:58] gc-core.c(313): GC started. Total block number is 835.
[11/27/17 10:05:58] gc-core.c(46): GC index size is 1024 Byte.
[11/27/17 10:05:58] gc-core.c(327): Populating index.
[11/27/17 10:05:58] gc-core.c(181): Populating index for repo 7151f4aa.
[11/27/17 10:05:58] gc-core.c(234): Traversed 2 commits, 929 blocks.
[11/27/17 10:05:58] gc-core.c(341): Scanning and deleting unused blocks.
[11/27/17 10:05:58] gc-core.c(364): GC finished. 835 blocks total, about 929 reachable blocks, 0 blocks are removed.

[11/27/17 10:05:58] gc-core.c(456): === GC is finished ===
seafserv-gc run done


What is your file history and trash settings? Did you destroy library over admin panel? (Admin panel -> Libraries -> trash)

No I did not destroy the library, all I did was to delete ONE file of the library, then deleted it from the trash bin too.

Sorry missed word “file” so I read you are trying delete 5GB library.

My question is there still. If you delete file, it will stay in block and in trash. seaf-gc work with library history and trash settings. So if you have “keep always” they are never destroyed by seaf-gc.

Where do I set this option?

In list of libraries

Thank you very much!
What is this option for? Can you recover files with this?

Seafile keep history of files in libraries, changes, deleted (in trash) and you can recover every single version of changed file. This option setup how far this history should go (to reduce disk usage). But it not work automatically, what I understand, this is only option for seaf-gc which you have to run manually on CE edition

Thanks, @holantomas! Saved my life.
Deleted unwanted huge files, changed Library history settings as indicated above and then run
In my case, running Seafile as a Docker container, that was run as:
docker exec -it seafile /opt/seafile/seafile-server-latest/