Deleted Files SeaDrive


I’ve posted this issue before but this time i have discovered something much worst. One of the users SeaDrive client ( 0.8 ) Windows 10, in the history log is showing as he deleted multiple files and directories, this was the issue I reported earlier, but now, it not just deleted the files, it left a “ghost” file of 0kb, it would make it very hard to detect. All files are gif,png and jpg. Again, their logs don’t show anything apart from a sync issue which after it skips. I`m afraid I will have to give up on SeaFile all together as its not reliable.

Having the option to go into snapshots and restore the files is brilliant, but having to do this every 1-2 weeks for random files is just not worth it.

Hope no one else is have such issues and if the do… have you found a fix for it? The only thing I could think of is that the user is using a laptop and sometimes he switches from a cable to wifi.

Still think Seafile is brilliant and constantly improving.

Thank you.

Hi @Valentin_Ciocan Can you try the new 0.8.2 version? We added more log messages. It may help find out the cause of this problem.

@Jonathan Can confirm ghosting files. In my case folders. But problem is that they are in seafile filesystem not only in seadrive client. They have no history and date change is unix epoch time 1970-01-01. The most freaking problem of this is that folders exists and are normaly used but in some subdir. For example see tree below:

 - / #root of library
   - some_dir/
     - 20171101_example_dir/ # this dir is normally used and contains files
     - ... #some other folders and files
   - 20171101_example_dir/ # this dir is created automaticly with no files and date change 1970-01-01
   - ... #some other folders and files

Problem is if I delete(tried via SeaDrive, Seafile client cloud browser and Seahub … same result) folder /20171101_example_dir/ it’s appear back after some hours and /some_dir/20171101_example_dir/ works perfectlly without issue. I installed 0.8.2 on three our workstation and clean logs but before I didn’t found any log or file history which indicate this problem. Will keep you up-to-date

I’ll give it a try today. A little side note, it can`t see the latest version when I go to About> Check for updates. I will reinstall it.

Thank you for this.