Deleted shared folder keeps coming back


I have a couple of folders (within shared folders) that keep coming back, although they have been deleted.

What can I do to delete it?

Greetings, Chris

I have the same issue. Here it’s a windows client recreaten the folders (it’s the recent seafile client version)

Hi Simsala

Did you get this to work?

sorry for the late answer. Unfortunately I have no more access to the windows machine wich always recreated deleted folders in the first level of the library.
But other users reported the same problem. I will try to get some seafile log from them.

Dear Forum

I still have this issue.
It’s a windows client with Version 6.0.6 on a seafile server 6.0.9 (community) that keeps putting back the files/folders.
Other clients are Mac and other windows clients (all up to date).

Is this a known issue?
Should I open a bug report for it?

Greetings, Chris

NTP/Time/Timezone correct?

It could be that this is the issue.

Thanks for the tip.
Actually I just saw that on one of my servers the ntp is working with 1 hour offset.

I will change this and check and will get back in the future if this is solved.

Talk to you later :wink:


Have one and the same NTP server for all machines if possible.


I have the exact same problem on a Seafile Pro Server version 6.1.3
As it is a customer library, I cannot check the NTP servers.
However, if I remove one the folders on a sunday or in the middle of the night, when the client machines are off, it still keeps comming back…
It takes a certain time to come back. It can be a few days or even weeks.

I am wondering if the problem isn’t linked to empty folders.

If anyone has an idea or a lead, it will be welcome !


Any updates regarding this issue? I have the same issue where two specific files keep coming back. In addition, they keep recreating a conflict file at the same time. I tried completely removing the folder that is causing the issues from the source, but issue reoccurs again.

This problem doesn’t seem to interest many people appart from us it seems… Unfortunatelly !

The problem is probably that it is hard to reproduce, that makes it not easy to solve.

At least I didn’t succeed while trying to reproduce, but I’m quite sure that it was always the Windows Client which recreated the deleted folders.


I would suggest to shut down all clients one by one to see, if the recreation is related to a single client. If it is, try to unsync the library and sync it again. If the folders still reappear, I would stop the client, delete the .seafile-data folder within the Seafile base dir (at least it’s located there when you use Linux), start the client again and sync the library with the existing local folder.

(It the error still persists, I personally would check my cron jobs and daemons next. :wink: )

BTW: Where is your Seafile base folder located?

Best regards



And thanks for your answers.
Unfortunately, the problem doesn’t happen here but at my customer’s company.
It is therefore difficult to stop the sync clients and turn them on one by one for testing.
Especially when the folder reappears within days to weeks after being deleted!

If there is no software fix, I won’t be able to solve this problem.

Have a nice day !

Hello all,

We have the same issue - no solution yet. Only one client causes that for now. In our case it is a Win10 client. We have stopped sychro, uninstalled seafile from the computer, deleted all remanings in the registry, then we have done fresh install using seadrive and it happens again. We cannot get rid of empty folders, it does not matter who deletes them, but these are still coming back - after few hours or few days…
We will test it further when there is some more time for that.


The problem may be some hidden files cannot be deleted inside that folder. You can ask the user of that client to check the content of the folder.

Thanks for you answer.
According to the end user, there is no hidden file…
It is difficult to troubleshoot without the hands on the computer…

I have the same problem and actually unnistall seafile from the computers and I have only left seadrive in them and I have still the same issue. The folders appears without files, without date.

Some old version of SeaDrive had the issue of adding back deleted folders or files. A solution is to upgrade to latest version of SeaDrive. Then log out the account locally. When asked whether to clean the cache, choose yes.

It´s happen before I start using seadrive, just with seafile client, and then I start using the lastest release of seadrive, and the behavior is still there.