Docker Deployment Port/SSL Problem (HAProxy, Rancher, Seafile-Server)

Hello Seafile-Community :slight_smile:

I am a bit frustrated in deploying my seafile-server with docker. I hope you guys have some ideas to help me out with this. I will try to explain my problem a bit - please let me know if you need more information:

Gateway:

  • Opnsense with haproxy, auto-deploying ssl-certs for my services (it issues my certificates and uses them with haproxy to get a secure connection between user and opnsense).
  • Haproxy communicates with my services in ssl or non-ssl. I can set this option in my backends.

Docker:

  • CentOS newest release
  • Rancher v2 (Kubernetes)
  • For testing purposes firewall disabled - will re-enable it after deploying seafile
  • Ingress: It seems seafile needs ingress to successfully deploy and use with seafile.domain.tld (port80/443).

My Problem(s):

  • I can deploy the seafile-container without any problem
  • I can connect via IP:80
  • I can connect via DNS:80 (seafile.domain.tld)
  • nginx inside the container ignores every of my configurations (deletion after redeploying) - auto-generated new file with port 80
  • I only can deploy my container with nginx on http/port 80
  • I cant use Lets Encrypt at this point because I want to issue my certs with my opnsense
  • I cant use my own certificates mentioned in the manual - I added them to /shared/ssl (inside the container).
  • I also tried to set the Enivronment-variable “SEAFILE_USE_HTTPS”=1 - found that on anothe topic - the container seems to ignore it

My deployment-configuration in Rancher:

Environment-variables:
SEAFILE_SERVER_HOSTNAME=seafile.domain.tld
SEAFILE_ADMIN_EMAIL=*****
SEAFILE_ADMIN_PASSWORD=****

Image:
seafileltd/seafile:latest

Ports:
tried everything I think :smiley: The problem is, that I only can use 80/tcp and 443/tcp if I use the rancher/kubernetes ingress-controller. So I set it up and can connect (only with port 80!). Nginx - is still on port 80.

My Question(s): How should I deploy my container? I would like to use it with 443/tcp to secure the connection between haproxy and the container - but I am not able to use that. Long story short: Please help me with this :smiley:

Thank you guys and have a nice day!

atomique

Ps.: I followed this documentation: https://manual.seafile.com/deploy/deploy_with_docker.html

Hello guys,

I just found my mistake!

Solution: I found out, that I’ve missed a rule inside my haproxy. Thank you guys for taking the time to read my post :slight_smile: Sometimes it needs a break in deploying applications to see everything from another point.

I only have to further problems with ldaps and nginx, but I will open a new topic for this.

Have a nice weekend!

atomique