Dowloading files fails in Android app and web interface


#1

I have configured seafile behind a nginx server.
The desktop client for linux (seafile-applet) works fine. I can see my libraries, the libraries are correctly synced and I can even download specific files explicitly.

Also viewing my libraries works via the web interface and via android app. However in both systems I am not able to download any files. The android app only tells me that downloading failed. I didn’t find a way to get any more information about the problem.
When trying to download a file via the web interface, I can see that the download tries to access port 8082 (for example: http://myserver:8082/files/0e16b785-30ca-450c-a2bc-32f73eaeffe9/myfile, which cannot work, since this port isn’t open to the public (it should always go through the ngingx server via port 443).
I assume that the android app has the same problem.

What can the problem be? Is it a configuration issue in the nginx server? Or a configuration issue in the seafile application? However, the deskrop client works fine, so I assume both configurations should be correct.

I can post configuration snippets, if necessary.


#2

Hey,

the url is generated by seafile, so I think somewhere in your seafile configuration you have added the port. It could be the SERVICE_URL in the ccnet.conf.
Can you download the file when you omit the port (e.g. http://myserver/files/0e16b785-30ca-450c-a2bc-32f73eaeffe9/myfile) ?
See https://manual.seafile.com/deploy/deploy_with_nginx.html


#3

Hi, ccnet.conf specified the SERVICE_URL as https://myserver:8000 (which is not 8082).
I have changed this and removed the port and it didn’t change anything.

I did a grep for 8082 over the conf directory and the only value that was found was in seafile.conf: port = 8082

Just removing the port from the URL doesn’t work either. A seafile-generated website is presented saying that the page could not be found.

Any other ideas?


#4

Some settings can be set with the web interface. Maybe something is wrong here?


#5

Yes! That’s it! I can’t remember having configured anything via the web interface, but obviously the entry there was overriding the ccnet.conf. After changing it in the web interfance it works as expected.

Many thanks!


#7

I had a similar issue. But I used the HTTP Seahub web server in order to connect to Seafile webinterface. The connection was via my DynDNS account. I also tried to install Seafile on my Raspberry Pi. Nothing worked.


#8

So I changed the HTTP_SERVER_ROOT to http://:8082. I also opened Port 8082 in my Router.