Empty folder on Debian without Gui

Hi,
I’ve just installed SeaDrive Client on Debian 10, folowing your doc.
I worked at first launch, with command :
$ seadrive -c ~/seadrive.conf -d ~/.seadrive/data -l ~/.seadrive/logs/seadrive.log ~/seadrive

But now each time I relaunch, all 'Share with *" and “My libraries” are empty.

The log says :
[07/29/20 17:26:49] seadrive.c(622): Starting SeaDrive client 2.0.3
[07/29/20 17:26:49] repo-mgr.c(3291): switching account to https://seafile.mydomain.org my.mail@mydomain.org.
[07/29/20 17:26:49] seadrive.c(650): rpc server started.

I try to clean .seafile/data folder but that did not help.

1 Like

You should check you configuration file for errors.

The config file is fine,
if I run the seadrive command with -f option, there’s no problem.
$ seadrive -f -c ~/seadrive.conf -d ~/.seadrive/data -l ~/.seadrive/logs/seadrive.log ~/seadrive

I’ll will use tmux to maintain the session.

1 Like

Same issue here. I have to run with -f or it does not load my libraries.

It seems that if I run it with -f once to get the -d ~/.seadrive/data directory setup and then run without -f, everything is still loaded, but I did not test to see if everything works after.

The -f option is required. It’s a system limitation.