Err:11 http://deb.seadrive.org jessie Release 401 Unauthorized [IP: 104.18.59.193 80]

seadrive

#1

The Ubuntu/Debian PPA Seafile Drive Client has this error when you do an apt update and can’t be installed!

Here is the errors when I try to update the repo…

Err:11 (http)deb(dot)seadrive(dot)org jessie Release
401 Unauthorized [IP: 104.18.59.193 80]

E: The repository ‘(http)deb(dot)seadrive(dot)org jessie Release’ does not have a Release file.
N: Updating from such a repository can’t be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

What’s going on? Why can’t install the Seafile Drive Client? I followed the instructions on the Using Seafile Drive Client on Linux Help Center page.

I’m using Ubuntu 18.04 and I had to remove the ppa /etc/apt/sources.list.d/seafile.list file in order to complete an update!

It was working before, but it’s not now.


#2

Same here, im using “deb http://deb.seadrive.org stretch main”.


#3

I tried that but still the same error. Something is wrong with the release file, from what the error states.


#4

Confirm this on Ubuntu 18.04.1 LTS (kernel 4.15.0-45-generic). This repo was working fine about a week ago. I didn’t make any changes in configuration files.
/etc/apt/sources.list contains this line “deb http://deb.seadrive.org bionic main”.


#5

I can also confirm that it was working a week ago… something happened in the last few days!


#6

The Release file downloads an HTML page that automatically redirects to some page that looks like a Procter&Gamble internal portal (but could also be a phishing page).

Check this URL (remove the spaces): http :// deb. seadrive. org/debian/dists/stretch/Release


#7

There’s something really strange going on with their repo.

The pg.com address it redirects you to is legit. The reason for the redirection is what the main question is now.


#8

For Debian, just use Seafile Client from Debian backports. It’s build with a few more fixes and is faster updated than seafile’s one.


#9

It would appear that there is an issue with the repo, I am trying this on Ubuntu 18.04 and I did this:

sudo apt-key adv --keyserver hkp://keyserver.ubuntu.com:80 --recv-keys 8756C4F765C9AC3CB6B85D62379CE192D401AB61
echo deb http://deb.seadrive.org bionic main | sudo tee /etc/apt/sources.list.d/seafile.list

This is the same as the guide on Seafile’s site except it switches jessie for bionic. This appears fine until I run sudo apt-get get update which results in an error

Err:5 http://deb.seadrive.org bionic Release                      
  401  Unauthorized [IP: 104.18.59.193 80]

When I visit the url of a deb file on the deb url, specifically
[seadrive-deb-domain]/bionic/pool/main/s/seadrive-daemon/seadrive-daemon_0.9.5_amd64.deb

I am then redirected to a P&G single sign on page, which does not make sense.

It would appear that something is misconfigured with respects to the deb server. When will the deb server be online?


#10

I tested this on CentOS and the RPM repos are experiencing a similar issue.


#11

Isn’t there a PPA for Ubuntu?


#12

There is no PPA for seadrive, only for the syncing client. I think OP intended for this to be about seadrive, but tagged it as Seafile Client.


#13

Ah ok. But I think the big problem is why SeaDrive can’t be open. This have to change. Additionally, they do no marketing for their good products. With this direction, they’ll never get more important.


#14

I agree completely, this is a bit concerning, that the servers can disappear and these files are nearly impossible to find. On top of that it shows how reliant we are off of these unreliable services, which would not be the case if it were OSS.


#15

To me it looks like the server that previously hosted the stuff is either down or has a new IP and that the old IP address is currently owned by someone else


#16

You’re correct… I fixed the tag. I didn’t even noticed I used the wrong tag… thanks for the heads up!
Cheers!


#17

Does anyone have the deb packages??


#18

Wow… no word from the devs on this? That’s troubling.


#19

I tried emailing their support. Maybe we should find them on another service and reach out. This is frustrating as it prevents many people from setting things up.


#20

@daniel.pan