Err:11 http://deb.seadrive.org jessie Release 401 Unauthorized [IP: 104.18.59.193 80]

seadrive

#9

It would appear that there is an issue with the repo, I am trying this on Ubuntu 18.04 and I did this:

sudo apt-key adv --keyserver hkp://keyserver.ubuntu.com:80 --recv-keys 8756C4F765C9AC3CB6B85D62379CE192D401AB61
echo deb http://deb.seadrive.org bionic main | sudo tee /etc/apt/sources.list.d/seafile.list

This is the same as the guide on Seafile’s site except it switches jessie for bionic. This appears fine until I run sudo apt-get get update which results in an error

Err:5 http://deb.seadrive.org bionic Release                      
  401  Unauthorized [IP: 104.18.59.193 80]

When I visit the url of a deb file on the deb url, specifically
[seadrive-deb-domain]/bionic/pool/main/s/seadrive-daemon/seadrive-daemon_0.9.5_amd64.deb

I am then redirected to a P&G single sign on page, which does not make sense.

It would appear that something is misconfigured with respects to the deb server. When will the deb server be online?


#10

I tested this on CentOS and the RPM repos are experiencing a similar issue.


#11

Isn’t there a PPA for Ubuntu?


#12

There is no PPA for seadrive, only for the syncing client. I think OP intended for this to be about seadrive, but tagged it as Seafile Client.


#13

Ah ok. But I think the big problem is why SeaDrive can’t be open. This have to change. Additionally, they do no marketing for their good products. With this direction, they’ll never get more important.


#14

I agree completely, this is a bit concerning, that the servers can disappear and these files are nearly impossible to find. On top of that it shows how reliant we are off of these unreliable services, which would not be the case if it were OSS.


#15

To me it looks like the server that previously hosted the stuff is either down or has a new IP and that the old IP address is currently owned by someone else


#16

You’re correct… I fixed the tag. I didn’t even noticed I used the wrong tag… thanks for the heads up!
Cheers!


#17

Does anyone have the deb packages??


#18

Wow… no word from the devs on this? That’s troubling.


#19

I tried emailing their support. Maybe we should find them on another service and reach out. This is frustrating as it prevents many people from setting things up.


#20

@daniel.pan


#21

Same problem here on linux mint 18.3


#22

#23

Here is another user experiencing issues.


#24

Still no word on this? Anyone get it working yet?


#25

But it is the same problem for Seafile command line client because https://help.seafile.com/en/syncing_client/install_linux_client.html#wiki-debian says for Debian installation:

echo deb http://deb.seadrive.org stretch main | sudo tee /etc/apt/sources.list.d/seafile.list

So thx @bionade24 for the hint to install via backports!


#26

The problem should be fixed now.

The reason was our nginx server tries to connect to a stale upstream server (due to this dns caching problem): https://trac.nginx.org/nginx/ticket/1064

Thanks all for reporting this and feedback! And sorry for the late reply - during this week the whole team have been on holidays for the Chinese traditional new year. We’ll see how to setup proper monitoring for it.


#27

Thanks for the update lins05.

Please disregard this post, it my fault for not changing the ‘jessie’ tag with the ‘bionic’ one. User error LOL!!!


#28

working good now. thanks !!