Error at Seahub admin configuration - Ubuntu 22.04 with Seafile 9.0.10

Hi guys - I’ve attempted at least 4-5 installs today of 9.0.10 and while I can get close, I can’t get all the way there. I will be the first to admit I am a Linux noob, but I can follow the bouncing ball and type in commands. I’m using the standard Seafile manual and LOTS of searching of the forum as I run into errors and issues that aren’t called out specifically. I’ve put together a step-by-step record of my install process (based on the standard manual, but with fixes included) to try to find where it’s breaking. I’m assuming it’s something stupidly easy but will admit I’m at a loss at this point. I would really like to move off of my Seafile 6.0.7 running on Windows but am stuck unless I can get this sorted.

I’ll note after step 32.2, I do get the following error warning prior to going into Seahub config. Not sure how critical this is, but something weird.

LC_ALL is not set in ENV, set to en_US.UTF-8
./ line 228: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8): No such file or directory

Any assistance would be hugely appreciated!

Setup Ubuntu

1. Install Ubuntu 22.04.1 LTS
2. sudo apt update
3. sudo apt upgrade

Setup MySQL

4. sudo apt install mysql-server
5. sudo service mysql start
6. sudo mysql
7. ALTER USER 'root'@'localhost' IDENTIFIED WITH mysql_native_password BY 'password';
8. exit
9. sudo mysql_secure_installation (enter ‘password’ for root)
    1. Validate password component – N
    2. Change password for root – Y or N
    3. Remove anonymous users – Y
    4. Disallow root login remotely – Y
    5. Remove test database and access to it – Y
    6. Reload privilege tables now – Y

Installing Prerequisites

10. sudo apt-get update
11. sudo apt-get install -y python3 python3-setuptools python3-pip libmysqlclient-dev
12. sudo apt-get install -y memcached libmemcached-dev
13. sudo pip3 install --timeout=3600 django==3.2.* Pillow pylibmc captcha jinja2 sqlalchemy==1.4.3 \django-pylibmc django-simple-captcha python3-ldap mysqlclient pycryptodome==3.12.0
14. sudo mkdir /opt/seafile
15. cd /opt/seafile

Creating user ‘seafile’

16. sudo adduser seafile (enter/re-enter password, add user information if desired)
17. sudo su (to get to ‘root’)
18. cd etc
19. visudo
20. At end of file, add seafile ALL=(ALL) NOPASSWD:ALL
21. Exit and save
22. su seafile
23. sudo chown -R seafile: /opt/seafile

Downloading and uncompressing the install package

24. wget
25. tar xf seafile-server_9.0.10_x86-64.tar.gz

Setting up Seafile CE

26. cd seafile-server-9.0.10 
27. ./
    1. Enter server name
    2. Enter IP address
    3. Assign port for fileserver (default 8082)
    4. Create new ccnet/seafile/seahub databases or use existing
    5. Host of mysql server (default ‘localhost’)
    6. Port of mysql server (default 3306)
    7. Password of mysql root user (‘password’, unless changed in 6.1)
    8. Enter user name for mysql user of Seafile (default ‘seafile’)
    9. Enter password for mysql user ‘seafile’
    10. Database name for ccnet-server (default ccnet-db)
    11. Database name for seafile-server (default seafile-db)
    12. Database name for seahub-server (default seahub-db)

Edit configuration files and install cffi 1.14.6

28. cd /opt/seafile/conf
29. nano
    1. Add port 8000 to the SERVICE_URL (i.e., SERVICE_URL = '').
30. nano 
    1. Change the bind to "" (i.e., bind = "")
31. sudo pip3 install --force-reinstall --upgrade --target /opt/seafile/seafile-server-9.0.10/seahub/thirdpart cffi==1.14.6

Starting Seafile Server

32. cd /opt/seafile/seafile-server-latest
    1. ./ start # starts seaf-server
    2. ./ start  # starts seahub
33. Seahub configuration
    1. Enter email for admin account
    2. Enter/re-enter admin password

Error happened during creating seafile admin.

Seahub is started.


Can you share the error upon creating the Seafile admin here? You can also refer to this post here, seems like its similar to your issue: