Error update 5.0 _5.1

I am trying to upgrade from 5.0 to 5.1 and get the error:


Updating seafile/seahub database …

[INFO] You are using MySQL
[ERROR] Python MySQLdb module is not found

Failed to upgrade your database


But… Package MySQL-python-1.2.3-0.3.c1.1.el6.x86_64 already installed and latest version
Python installed version 2.7 of the src.
Centos 6.5 x86_64

Try this command, and see what’s the output:

python2.7 -c "import MySQLdb; print MySQLdb.__file__"

Traceback (most recent call last):
File “”, line 1, in
ImportError: No module named MySQLdb

Then the python you installed from src doesn’t work with your installation of MyQL-python.

Since you mention you’re upgrading from seafile 5.0 to 5.1, does it (python installed from src and MySQL-python installed from yum) work with seafile 5.0?

I’d suggest you install python 2.7 with yum if possible.

Yes, seafile 5.0 works fine. Python 2.6 installed and it works fine mysql module.
I installed python 2.7 through yum, but the mysql-python does not see :frowning: