Error when trying to sync libraries: 'Argument can't be NULL'


#41

All backup applications I’ve administered retain the dates when they’re restored. Amanda, BackupPC, Borgbackup, ShadowProtect, plain old rsync…

Try xcopy or robocopy to copy files from one Windows machine to another - one of those (with the correct flags) can definitely preserve file dates (I just forget which one).


#42

I think I gave up about 15 years ago, lol… Back in the DOS days, it was more consistent than it is now… OS’s these days tag with metadata, complicating matters.


#43

i have the same error for my seafile server. At this morning all was ok, but now all clients can’t sync new librarys. I’m upgrade server & clients, but i still getting error. There is no mention in logs for something linked with this events.
My actions with seafile today is tune server to work via nginx, but i rollbacked to old config and error still with me.


#44

What OS are you using? If you use one of the tested OSses, rolll out backups :expressionless:


#45

for server is ubuntu 16.04, clients - windows 7,10, ubuntu 14.04,16.04.
Sad news.


#46

I would roll out backups :sob:


#47

Hey. I’m made this work again!! :grinning:
So, like i read above, @deryo have a problem happens while he config seafile running behind nginx. So am i. I’m digged out, what changes i made and one of it was modify SERVICE_URL & FILE_SERVER_ROOT.
Modify can be done both, via web interface (and it saves into mysql table and have higher priority against config files), and via config files.
Before changes there is no settings via sql table, but when i made changes, i did it via web interface. When problem happened, i changed back settings of directives, and i did it via webinterface too.
Now i truncate table where this settings stores (seahub-db/constance_config) and back settings in config files and librarys start syncing again.
So, problem was in settings that stored in mysql. May be it’s a bug, i opened it. Hope this will be helpful to somebody!:slight_smile:


#48

He was running sqlite, though.


#49

I did follow your steps and it (kind of) worked. After a few days wrong settings appeared in the admin page for file_server_root. I absolutely do not have any idea where the wrong settings came from. I changed the value to the values in ccnet.conf and now it (kind of) works again.

Why ‘kind of’? Some of my libraries just don’t sync. The client says “connecting server…” but nothing more. I found three threads regarding this issue here in the forum, none with a solution.

It seems that the relationship between seafile and me has a hard time…


#50

HI,

I have the same issue as you.

I don’t think is related to proxy because windows client is working fine

Regards


#51

Have you tried what Boris proposed here?


#52

I did not truncate seahub-db/constance_config but setting stored here are the same as in config files, so i don’t presume they are involved.

Other Windows Client can sync. The issue is restricted to Seaf CLI (Linux Debian)

Regards