Failed to start ccnet-server and seaf-server

Hi,
I’m trying to develop env for Seafile.
I’ve downloaded and build Seafile and everything was ok.
Now I’m trying to start ccnet-server and seaf-server as is in manual and it doesn’t work.
I’m doing:

Start ccnet-server and seaf-server in two separate terminals.
1/

cd ~/dev/seafile-server/tests
ccnet-server -c conf -f -

2/

cd ~/dev/seafile-server/tests
mkdir -p conf/seafile-data
touch seafile-data/seafile.conf
seaf-server -c conf -d conf/seafile-data -f -l -

My errors:
1/ ‘failed to start ccnet session’
2/ ‘cannot touch ‘seafile-data/seafile.conf’: No such file or directory’ and ‘can’t load config file’

Why it doesnt’ start ccnet-session and why system requires ccnet.conf file from ~/dev/seafile-server/tests/conf if there is no files in this path?

seafile.conf is located in the /conf folder, not the seafile-data folder. Unless you moved it…

If you have placed it in conf/seafile-data, then your touch may need to reflect that.

touch conf/seafile-data/seafile.conf

I didn’t move anything. I’m doing everything with manual and don’t make any ‘my’ moves.
But first of all, I have problem with first command.
cd ~/dev/seafile-server/tests
ccnet-server -c conf -f -
It threw ‘failed to start ccnet session’ error.

And second command.
I made your command ‘touch’ and still it isn’t working. I’m attaching prt scr with errors.

What am I doing wrong?

You are starting ccnet-server from the tests folder and specifying it to use the conf folder under that folder. However, it is reporting that it cannot load ccnet.conf from that folder, /home/artur/dev/seafile-server/tests/conf/ccnet.conf.

First, verify that the file exists in that folder.

Then, you are creating a folder called seafile-data under the conf folder and then trying to find seafile.conf there, which certainly won’t exist.

The seafile.conf and ccnet.conf files will be located in /conf under whatever folder you originally installed seafile in on install. In your case, it appears to be /home/artur/dev/seafile-server.

So, your conf folder is probably /home/artur/dev/seafile-server/conf, which is different, not only from where you try starting ccnet, but also from you are telling ccnet that it is located.

Where did the folder “tests” come from?

Which manual are you referencing, btw? Which section?

I thought problem is what you have write.
But what’s next step? Should I copy files (I think not) or should I start ccnet and saef server from “/home/artur/dev/seafile-server”?

Section in manual I am talking about is Develop env in Developing chapter.
https://manual.seafile.com/develop/env.html

I finished section “Linux” in Developing chapter.
I thought next step is develop env and I can finally go to API V2.1 section.
Is it correct order of developing seafile?

Ok… I just read through that section of the manual. First off, there is some deprecated information in there, such as running in fastcgi mode. But, that isn’t your problem. I only mention it because there may be some other information that has changed since this section was last updated and it may be deprecated as well.

Let’s navigate to /home/artur/dev/seafile-server/tests/conf and then see if ccnet.conf exists. If so, post it here. If not, we need to figure out what went wrong.

Then, navigate to /home/artur/dev/seafile-server/tests/conf/seafile-data and check to see if seafile.conf exists. If so, post it here. If not, we need to figure out what went wrong.

Then, navigate to /home/artur/dev/seahub, and cat setenv.sh and post the results here.

Then, in the same folder, ls -al | grep setenv, and post the results here.

Also, that extra dash at the end of the ccnet-server line appears odd to me. I know it’s that way in the manual, but I’m not certain it’s correct. Another thing I noticed is the . setenv.sh… The dot looks suspicious to me as well… usually, to run a script, it’s ./setenv.sh… But, we aren’t to that point yet, so we’ll worry about that one when we get to it.

HI, thank you for your help.
About this:
1/

I don’t have any files here. Only seafile-data folder.

2/

seafile.conf exist, but it’s empty.

3/

There’s a space after “ls”… That’s why that command didn’t run. Make sure you type "ls -al | grep setenv

  1. That’s why it’s failing to start… There is no ccnet.conf file in that folder.

  2. That’s also why you are having a problem. Your seafile.conf file is empty and has no settings.

  3. Ok. So, that seems to be correct, but the “~” means it is pointing to your home directory. Run this command and let me know the results: echo $HOME