Failure after changing IP

I changed the host IP address of Seafile Server, and updated Seafile Client settings to reflect the change. Now, my client stalls on “waiting for sync”, and Seafile Logs shows error:

http-tx-mgr.c(783): libcurl failed to GET ,/seafhttp/protocol-version: Failure when receiving data from the peer.

What I do, the client seems to try to connect to the former (now removed) IP address.

Any help would be appreciated

Update: I removed all of my accounts from the client and re-added them, but the client still will not synch any libraries and creates the same error message mentioned above.

Any suggestions would be appreciated

cc: @jonathan, @daniel.pan, @92lleo

Disclaimer: I don’t speak for seafile

I guess you’re using the same domain for your server and just changed the A/AAAA Records to reflect the new IP? Did you make sure the DNS was propagated everywhere? 4 days seems to be enough, still worth checking.
what happens when you ping your domain from a client? What ip does it show?

Thanks for your reply.

I don’t use a domain . I changed the IP of the server, but removed all accounts from the client that referenced the old IP. Whether I use the new IP or the LAN IP, I get the same error message in the log (trying to connect using the old IP).

Do you reconfigure the server’s SERVICE_URL and FILE_SERVER_ROOT?

1 Like

I just checked and those variables have been incorrectly set for years (long before this problem occurred). I just never updated the settings to the correct IP address. However, that did not fix the problem.

The error is only occurring in one particular client… Seaile Client works on other clients using these same settings, so I know Seafile Server is working correctly.

I’ve now re-installed Seafile Client (without removing the Seafile data folder), and still receive the same errors.

Does anyone know whether Seafile Client has a cache that can be cleared without deleting the entire data folder?


cc: @jonathan, @daniel.pan, @92lleo

You can try to uninstall the client and choose to remove account information. This bug of changing server address will be fixed in the next version.

Thank you for the help

I’m still having problems with this. I was happy to see a new release of Seafile Client, but I’m using Windows 7 so Client v. 8 won’t work. Can you offer any other suggestions?

Did you try this: