File path contains symbols that are not supported by the Windows system

in general, i think this is a good feature. i was able to rename all files in question to solve the syncing issues, except for one file. the seafile client claims its name is not valid allthough the file name in question is no longer in use, so this is like a zombie error, and i have no clue what to do about it. i removed the file, put it back again with a clean name, unsynced the library and resynced it again, the problem remains.

i would also prefer an option to turn this check off (ideally per library).

1 Like

the error even re-appears when in remove all data completely and sync the library with the server as if it was the first time – the file is created with its new name but the seafile client complains about the no longer existing file.

1 Like

QFT. I just came back from a holiday and I have this to deal with after I start my computer.

I do not have a Windows machine and I do not care about compatibility. This certainly shouldn’t have been a breaking change, but rather something to enable for new libraries, or something opt-in.

Are my files save or not? Are they synced or not? If I can’t get rid of all these permanent exclamation marks with sync error messages for this previously fine implementation, I’ll drop Seafile. I don’t have patience for this.

An update should never break your entire system like that.

1 Like

Can you revert to 8.0.0 or 8.0.1 while a solution is underway?

I ran a command to correct file names but I can well imagine that that approach might not be easily followed in many cases.

Is a solution underway? Can I track this somewhere? Can I technically revert to 801 without a footgun (e.g. “this database is for a newer version” type messages)?

On a Linux system, certain things generate files that are incompatible with Windows (because why should they) all the time. For example: User makes screenshots. They are automatically stored with the time in the filename i.e. a colon.

I don’t think the user is meant to manually rename every screenshot, unless they explicitly indicate Windows compatibility is relevant for and important to them.


Previous version might no longer be in repository for Ubuntu. At least I can’t choose it through the package manager.


You might want to post a comment (or two) about this on Seafile’s Github page. I’m pretty sure Development is monitoring both places and this issue should get the widest exposure as it affects non-Windows users in a big way.

Oh, the issue is already 7 days old Client complains about "symbols that are not supported by the Windows system". I don't have Windows. · Issue #2451 · haiwen/seafile · GitHub

@mercury @TheNomad11 commented at /haiwen/seafile/issues/2451#issuecomment-851047518 (cannot post links).

Same problem here. It’s really getting annoying badly (hundreds of messages to my Ubuntu notification area all the time.

The bad thing is that I don’t know whether the files are synced anyway or not.

Check here on github We’ll add an option in 8.0.3 version on the client to disable these notifications. For now you may downgrade to 8.0.1 version.

1 Like

Same problem here, I am bombarded with thousands of error notifications. I do not have a windows machine so obviously I do not care about compatibility with windows. It is impossible to rename all the files since many generated files carry the colon (files with timestamps or maildir-format mail directories for mail storage). The most annoying thing is that it is not clear if the files are synced or not. This seems like a bad feature since it breaks the entire system and it shouldn’t. At least give us the option to opt-out. For the moment I managed to downgrade to the previous version and things are ok for now, but I am not feeling comfortable updating seafile and seafile-client again. So probably I may have to find a replacement for it.

Such mistakes occur with all apps. And the devs are aware of the issue. For me, Seafile has been running without issues for a few years now, I find it much more reliable than Nextcloud, for example

As there is no possibility on openSUSE 15.2 to downgrade to 8.0.1, I would like to know, when the new version 8.0.3 is available.

(Ubuntu 20.04)

…however, if I simply touch a file in one of the directories which is affected, it seems to reset itself and remove the error … for now at least

~$ cd ./troubled_directory
~/troubled_directory$ touch some_random_file

That worked for me and my ~/Documents folder. Thanks!

I’m on seafile-client 8.0.3-1 and I still see this non-error error message. The “Hide Windows incompatibility messages” option is checked but doesn’t seem to do anything.


Make sure you’ve updated all the packages related to seafile client, especially seaf-daemon package.

This worked for me too. Thanks. Weird solution BTW

Its a fresh installation with latest “current” seafile version.

Just for documentation:
This command will find most filenames that are invalid on windows (run in the folder you are interested in).

find . -name '*[<>:"/\|?* ]*'

Even if you are not using windows it might make sense to correct the paths.