File_server_root $request_uri

managed to set up seafile with non-root-proxy - https, OK so far
implemented https-proxy at the main webserver of the subnet 100.0 - OK so far
implemented https-proxy at the main webserver of the subnet 0.0 for WAN-access - OK so far

But the problem is

HTTP_SERVER_ROOT = ‘http;\192.168.100.32/seafhttp’
FILE_SERVER_ROOT = ‘http;\192.168.100.32/seafhttp’

which should actually be sort like:
HTTP_SERVER_ROOT = ‘http;\$REQUEST_URI/seafhttp’
FILE_SERVER_ROOT = ‘http;\$REQUEST_URI/seafhttp’

And I do not see any reason why these params are in seahub_settings.py
AND in the SystemAdmin/Settings where

FILE_SERVER_ROOT = ‘https;\192.168.100.32/seafhttp’

which enabled up and downloads.

The problem: I do want to roll out an appliance with lot of servers for different clients
Everyone have its own FQDN and I want to avoid “hardcoding” these FQDN’s into every appliance.

Tks - willi